Bug 1567212 - It takes a long time to apply errata when running at Scale
Summary: It takes a long time to apply errata when running at Scale
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Errata Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Perry Gagne
URL:
Whiteboard: scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 15:01 UTC by sbadhwar
Modified: 2019-06-03 12:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Apply Errata Page (136.44 KB, image/png)
2018-04-13 15:01 UTC, sbadhwar
no flags Details

Description sbadhwar 2018-04-13 15:01:32 UTC
Created attachment 1421407 [details]
Apply Errata Page

Description of problem:
When trying to apply Errata updates to a large number of hosts, it takes a very long time for Errata install to prepare and the UI stays at the page as shown in the attachment for quite a lot of time.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Click on Content -> Errata
2. Select all the applicable errata from the list and click apply errata
3. Select a large number of hosts (preferably 6K or more)
4. Click on Next and then click apply.

Actual results:
Errata install process just holds on the page as shown in the attachment for a long time(30 mins+)


Expected results:
Errata install starts after some time.

Additional info:
The foreman debug can be found at: http://debugs.theforeman.org/foreman-debug-aA5Hr.tar.xz

Comment 2 Bryan Kearney 2019-05-02 19:06:54 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-06-03 12:05:42 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.