Bug 1567233 - UI unresponsive during provision via lifecycle, FATAL in production.log
Summary: UI unresponsive during provision via lifecycle, FATAL in production.log
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.3
Assignee: Tina Fitzgerald
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 15:38 UTC by Jan Zmeskal
Modified: 2018-05-04 13:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 14:53:27 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Zmeskal 2018-04-13 15:38:13 UTC
Description of problem:
When provisioning VM via lifecycle, UI becomes unresponsive. The provision cannot continue and cannot be cancelled. See the attached video.

Version-Release number of selected component (if applicable):
CFME 5.9.2.2.20180410215257_6961422

How reproducible:
Honestly, I have no idea how I got into that state. I was using my appliance for testing for some while, so the cause for this could have been anything. Hopefully the errors in logs might give you a hint.

Steps to Reproduce:
1. Go to Compute -> Infrastructure -> Virtual Machines. 
2. Click Lifecycle -> Provision VMs.
3. Choose a template to provision from.
4. Click Continue.

Actual results:
Continue button can be clicked, but does not actually do anything and the UI becomes unresponsive. 

Expected results:
I'd expect to continue with provision.

Additional info:
This error can be seen in production.log: 
production.log:259:[----] F, [2018-04-13T11:12:04.825998 #4843:116ecec] FATAL -- : Error caught: [NoMethodError] undefined method `get_timezones' for #<ManageIQ::Providers::Redhat::InfraManager::ProvisionWorkflow:0x0000000022922a30>

There are other errors as well, but this one seems to be the most relevant one.

Comment 6 Tina Fitzgerald 2018-05-02 14:26:45 UTC
John, I haven't been able to reproduce the issue.

Jan, can you setup a reproducer environment?

Thanks,
Tina

Comment 7 Jan Zmeskal 2018-05-02 14:38:41 UTC
Well this is obviously some very rare condition, because most of the time the provisioning of VM via lifecycle works OK. I unfortunately cannot reproduce this consistently either. I was hoping that the attached log could point you towards the cause of the issue.

Comment 8 Tina Fitzgerald 2018-05-02 14:53:27 UTC
Hi Jan,

I'm going to close this issue since we're not able to reproduce.
Please open a new ticket if the issue appears again.

Thanks,
Tina


Note You need to log in before you can comment on or make changes to this bug.