Bug 1567339 - authselect is blocking groupinstall 'Minimal Install'
Summary: authselect is blocking groupinstall 'Minimal Install'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: authselect
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Pavel Březina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 20:03 UTC by Miroslav Suchý
Modified: 2018-04-26 09:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 09:08:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Miroslav Suchý 2018-04-13 20:03:33 UTC
Description of problem:
I upgraded F27 to F28 (no problem there) and then I run:

dnf groupinstall 'Minimal Install'

I get:

 Problém: problem with installed package authselect-compat-0.4-1.fc28.x86_64
  - installed package authselect-compat-0.4-1.fc28.x86_64 obsoletes authconfig < 7.0.1-6 provided by authconfig-7.0.1-5.fc28.i686
  - package authselect-compat-0.4-1.fc28.x86_64 obsoletes authconfig < 7.0.1-6 provided by authconfig-7.0.1-5.fc28.i686
  - conflicting requests
  - installed package authselect-compat-0.4-1.fc28.x86_64 obsoletes authconfig < 7.0.1-6 provided by authconfig-7.0.1-5.fc28.x86_64
  - package authselect-compat-0.4-1.fc28.x86_64 obsoletes authconfig < 7.0.1-6 provided by authconfig-7.0.1-5.fc28.x86_64

It seems to me that both packages cannot be in comps file and one of them should be removed. See
https://fedoraproject.org/wiki/How_to_use_and_edit_comps.xml_for_package_groups

Comment 1 Pavel Březina 2018-04-16 08:31:35 UTC
Tomas, what is the status of retiring authconfig?

Comment 2 Tomas Mraz 2018-04-16 08:38:14 UTC
I will remove authconfig from comps for now. Retire will happen in Fedora 29.

Comment 3 Tomas Mraz 2018-04-16 08:45:54 UTC
https://pagure.io/fedora-comps/pull-request/267

Comment 4 Pavel Březina 2018-04-26 09:08:23 UTC
The PR has been merged. I'm closing this as not a bug since the problem was not in authselect itself.


Note You need to log in before you can comment on or make changes to this bug.