Bug 156738 - The requested URL could not be retrieved
The requested URL could not be retrieved
Status: CLOSED DUPLICATE of bug 156739
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
apartments.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-03 15:04 EDT by Gregory Gulik
Modified: 2014-08-31 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-03 15:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2005-05-03 15:04:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
Instead of my search results being displayed I get the following:

ERROR
The requested URL could not be retrieved

While trying to process the request:

GET /search/oasis.dll?Rent_Minimum=0&Rent_Maximum=9999&allsizes=1&threebdrm=1&am37=0&type_listing=1&cont.x=34&cont.y=17&mode=4096&current_criteria=%26area2%3DY%26subarea7%3DY%26allsizes%3D1%26allbaths%3D1%26state%3DIL%26rgn1%3D1%26prvpg%3D5%26type_listing%3D1%26srt1%3D0.35%26srt2%3D0.95%26srt3%3D0.72%26Rent_Minimum%3D0%26Rent_Maximum%3D9999&page=Results&area2=Y&subarea7=Y&state=IL&rgn1=1&prvpg=5 HTTP/1.1
Host: www.apartments.com
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Proxy-Connection: keep-alive
Referer: http://www.apartments.com/search/oasis.dll?subarea7=Y&cont.x=41&cont.y=10&page=Rent&area2=Y&Rent_Minimum=0&Rent_Maximum=9999&state=IL&rgn1=1&prvpg=4&type_listing=1
Cookie: IF_SessionCookie1=1115146736408; CP=null*; userId=172255032111350686724388; WSS_GW=V1z%%%Q%CrX%Q; CTG=1115146736; IFsess=37; accrueID=rent; srchid=2887332448111514182673768


The following error was encountered:

    * Invalid Response 

The HTTP Response message received from the contacted server could not be understood or was otherwise malformed. Please contact the site operator. Your cache administrator may be able to provide you with more details about the exact nature of the problem if needed.

Your cache administrator is root.
Generated Tue, 03 May 2005 18:59:03 GMT by server.gagme.com (squid/2.5.STABLE6) 

Version-Release number of selected component (if applicable):
squid-2.5.STABLE6-3.4E.5

How reproducible:
Always

Steps to Reproduce:
1. Open Mozilla and go to apartments.com
2. Choose Illinois
3. Choose 1 - Chicago & Vicinity
4. Choose 2 - Chicago - South
5. Choose 7 - South Loop
6. No need to change any defaults, just hit Continue

Actual Results:  RROR
The requested URL could not be retrieved

While trying to process the request:

GET /search/oasis.dll?Rent_Minimum=0&Rent_Maximum=9999&allsizes=1&threebdrm=1&am37=0&type_listing=1&cont.x=34&cont.y=17&mode=4096&current_criteria=%26area2%3DY%26subarea7%3DY%26allsizes%3D1%26allbaths%3D1%26state%3DIL%26rgn1%3D1%26prvpg%3D5%26type_listing%3D1%26srt1%3D0.35%26srt2%3D0.95%26srt3%3D0.72%26Rent_Minimum%3D0%26Rent_Maximum%3D9999&page=Results&area2=Y&subarea7=Y&state=IL&rgn1=1&prvpg=5 HTTP/1.1
Host: www.apartments.com
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Proxy-Connection: keep-alive
Referer: http://www.apartments.com/search/oasis.dll?subarea7=Y&cont.x=41&cont.y=10&page=Rent&area2=Y&Rent_Minimum=0&Rent_Maximum=9999&state=IL&rgn1=1&prvpg=4&type_listing=1
Cookie: IF_SessionCookie1=1115146736408; CP=null*; userId=172255032111350686724388; WSS_GW=V1z%%%Q%CrX%Q; CTG=1115146736; IFsess=37; accrueID=rent; srchid=2887332448111514182673768


The following error was encountered:

    * Invalid Response 

The HTTP Response message received from the contacted server could not be understood or was otherwise malformed. Please contact the site operator. Your cache administrator may be able to provide you with more details about the exact nature of the problem if needed.

Your cache administrator is root.
Generated Tue, 03 May 2005 18:59:03 GMT by server.gagme.com (squid/2.5.STABLE6) 

Expected Results:  I should be shown a list of my results.

Additional info:

This happens with both Mozilla on Linux as well as Internet Explorer on Windows XP whenever using the Squid proxy on RHEL4.

The search works perfectly when not using a proxy or using an older squid proxy such as squid-2.5.STABLE1-3.9 on a Red Hat 9 server I have here as well.
Comment 1 Gregory Gulik 2005-05-03 15:08:23 EDT

*** This bug has been marked as a duplicate of 156739 ***

Note You need to log in before you can comment on or make changes to this bug.