Bug 1567387 - dnf not functioning
Summary: dnf not functioning
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 22:15 UTC by R A Hamelin
Modified: 2018-04-26 17:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 11:25:22 UTC
Type: Bug


Attachments (Terms of Use)

Description R A Hamelin 2018-04-13 22:15:03 UTC
Description of problem: dnf not functioning


Version-Release number of selected component (if applicable):


How reproducible: 100%
                  

Steps to Reproduce:
1.dnf check-update
2.
3.

Actual results:
[rhamelin@hg001 ~]$ dnf check-update
Fedora Modular 28 - x86_64                                               237 kB/s | 159 kB     00:00    
Fedora Modular 28 - x86_64 - Updates                                     1.5 kB/s | 257  B     00:00    
Fedora Modular 28 - x86_64 - Test Updates                                524 kB/s | 400 kB     00:00    
Fedora 28 - x86_64 - Test Updates                                        5.5 MB/s |  16 MB     00:02    
Fedora 28 - x86_64 - Updates                                             1.2 kB/s | 257  B     00:00    
Fedora 28 - x86_64                                                       5.4 MB/s |  60 MB     00:11    
Last metadata expiration check: 0:00:00 ago on Fri 13 Apr 2018 02:46:13 PM PDT.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1015, in run
    self._process_demands()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 768, in _process_demands
    load_available_repos=self.demands.available_repos)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 454, in fill_sack
    self._setup_modules()
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 217, in _setup_modules
    module_metadata = ModuleMetadataLoader(repo).load()
  File "/usr/lib/python3.6/site-packages/dnf/module/metadata_loader.py", line 53, in load
    return modulemd.loads_all(modules_yaml)
  File "/usr/lib/python3.6/site-packages/modulemd/__init__.py", line 99, in loads_all
    m.loadd(doc)
  File "/usr/lib/python3.6/site-packages/modulemd/__init__.py", line 229, in loadd
    raise ValueError("The supplied metadata version isn't supported")
ValueError: The supplied metadata version isn't supported


Expected results: 
  Expected system to update


Additional info:
  This is a new install using Fedora-Server-dvd-x86_64-28_Beta-1.3.iso

Comment 1 Martin Hatina 2018-04-16 11:25:22 UTC
Fixed in dnf-2.7.5-9.fc28

Comment 2 Justin Barry 2018-04-26 17:52:43 UTC
The version of Fedora Server Beta that I downloaded came with dnf-2.7.5-8.fc28 meaning I still encountered the error described above.
I couldn't figure out how to update to a later version of dnf when every dnf command I tried was giving me this error.
I went to the fedora-server irc channel and a user there suggested disabling the fedora modular repositories.
I ran this command: 'rpm -e fedora-repos-modular'.
Which allowed me to run 'dnf update dnf' without getting the error.
Then I reinstalled fedora-repos-modular with 'dnf install fedora-repos-modular'.
And since I now have dnf-2.7.5-12.fc28 I don't encounter the error anymore.


Note You need to log in before you can comment on or make changes to this bug.