Bug 156748 - netcdf-devel doesn't require netcdf
Summary: netcdf-devel doesn't require netcdf
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: netcdf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ed Hill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 21:28 UTC by Konstantin Ryabitsev
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-01 21:28:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Konstantin Ryabitsev 2005-05-03 21:28:18 UTC
Description of problem:
netcdf-devel doesn't require netcdf. It probably should.

Version-Release number of selected component (if applicable):
netcdf-0:3.6.0-0.2.beta6.i386

Comment 1 Ed Hill 2005-05-05 20:24:58 UTC
Thank you for the bug report!  Its now fixed in CVS and I'm 
about to request a build so it should be available soon.

Comment 2 Michael Schwendt 2005-05-05 20:53:25 UTC
On Dec 4th 2004 you disagreed according to %changelog.


Comment 3 Ed Hill 2005-05-05 21:23:24 UTC
Yes, Michael, you're right.  I did disagree back then.  But I reserve 
the right to change my mind occasionally.  If Konstantin is actually 
using netCDF and wants the Requires then I think thats OK.

Comment 4 Konstantin Ryabitsev 2005-05-05 21:30:40 UTC
Well, actually, it was one of the build requirements for a scientific package I
was building, and I noticed that netcdf-devel didn't install netcdf. I figured
it was odd, so I filed the bug saying it *probably* should require it. Looking
at it closer, I see that there is no particular reason why it should, since
there are no .so files or anything of the sort.

Generally, I think it should require it if only because it's more consistent
with other packages and looks like a bug otherwise. Case in point being me. :)

(I do notice .a files, though, which are probably erroneously there, but that's
not related to this bug).

Comment 5 Michael Schwendt 2005-05-05 21:40:20 UTC
Umm, I don't object, just wanted to point it out, because (1) netcdf-devel
really doesn't need to depend on netcdf, and (2) the original reason for not
making it require netcdf was to allow for parallel installation of a future
netcdf v4 -devel package.


Comment 6 Michael Schwendt 2005-05-05 21:47:17 UTC
Fedora Extras does not allow any kind of package conflicts or explicit
"Conflicts", though, so whether this dependency is created or not, has no
consequences.


Note You need to log in before you can comment on or make changes to this bug.