Bug 15675 - random IPs in /var/lock/samba/namelist.debug (probably memory corruption)
random IPs in /var/lock/samba/namelist.debug (probably memory corruption)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 15:37 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 15:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-08-07 15:37:24 EDT
Samba puts some strange IPs to /var/lock/samba/namelist.debug.

This is an example:
Some strange IP 112.25.24.64 which has 
nothig to do with the network where SAMBA is running.
This IP changes from time to time.
Next time I start SAMBA the IP is 16.24.24.64.
Looks like some kind of memory corruption in SAMBA.

Subnet WINS_SERVER_SUBNET
----------------------
	Name = *<00>	Source = PERMANENT_NAME
b_flags = 44	death_time = PERMANENT	refresh_time = Mon Aug  7 09:17:43 2000

		number of IPS = 2	192.168.10.1	112.25.24.64

	Name = *<20>	Source = PERMANENT_NAME
b_flags = 44	death_time = PERMANENT	refresh_time = Mon Aug  7 09:17:43 2000

		number of IPS = 2	192.168.10.1	112.25.24.64

	Name = CLIENTDOMAIN<00>	Source = REGISTER_NAME
b_flags = c4	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	255.255.255.255

	Name = CLIENTDOMAIN<1c>	Source = REGISTER_NAME
b_flags = c4	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	192.168.10.1

	Name = CLIENTDOMAIN<1e>	Source = REGISTER_NAME
b_flags = c4	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	255.255.255.255

	Name = CLIENTHOST<00>	Source = REGISTER_NAME
b_flags = 46	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	192.168.10.1

	Name = CLIENTHOST<03>	Source = REGISTER_NAME
b_flags = 46	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	192.168.10.1

	Name = CLIENTHOST<20>	Source = REGISTER_NAME
b_flags = 46	death_time = Sun Aug 13 09:17:43 2000
	refresh_time = Mon Aug  7 09:37:43 2000

		number of IPS = 1	192.168.10.1

	Name = __SAMBA__<00>	Source = PERMANENT_NAME
b_flags = 44	death_time = PERMANENT	refresh_time = Mon Aug  7 09:17:43 2000

		number of IPS = 2	192.168.10.1	112.25.24.64

	Name = __SAMBA__<20>	Source = PERMANENT_NAME
b_flags = 44	death_time = PERMANENT	refresh_time = Mon Aug  7 09:17:43 2000

		number of IPS = 2	192.168.10.1	112.25.24.64
Comment 1 Henri Schlereth 2001-01-21 09:34:07 EST
Both those IP addresses are valid IP addresses. I doubt that this is memory corruption. Is your machine on the Internet?
Do you have ports 137-139 firewalled off on your external interface? Do you have samba listening only on the internal
interface? Do you have the hosts allow set in smb.conf?

I am unable to duplicate this on a machine that does run samba and is firewalled.
Comment 2 mal 2001-01-29 17:05:33 EST
This specific machine is not available to me any more (A lot of time passed
since 2000-08-07),
I will post all the information how it was set  back then.

>Is your machine on the Internet?

This specific machine is NOT on the internet. 
It has 2 network interface (both not seeing from the inernet)
190.1.0.0/16 and 192.168.10.0/24
The 190.1.0.0/16 may be considered as "external" interface.
It goes through masquerading Linux box to the internet.

> Do you have ports 137-139 firewalled off on your external interface
Yes.

>Do you have samba listening only on the internal   interface
Yes, it set to listen on 127.0.0.0/8 and 192.168.10.0/24 only.
But samba uses this option for port 139 only, for 137 and 138
it listens all interfaces anyway.
The settings were:
   interfaces = 127.0.0.0/255.0.0.0  192.168.10.0/255.255.255.0
   bind interfaces only = True

>Do you have the hosts allow set in smb.conf?
No
Comment 3 Trond Eivind Glomsrxd 2001-06-18 12:29:14 EDT
Can't reproduce - I assume it's fixed in a newer version.

Note You need to log in before you can comment on or make changes to this bug.