Bug 1567649 - [RFE] A vfio-pci port needs to be rebind to eliminate "/dev/vfio/X Permission denied" error
Summary: [RFE] A vfio-pci port needs to be rebind to eliminate "/dev/vfio/X Permission...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Aaron Conole
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-15 18:49 UTC by Jean-Tsung Hsiao
Modified: 2018-09-11 14:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-11 14:40:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jean-Tsung Hsiao 2018-04-15 18:49:45 UTC
Description of problem: [RFE] A vfio-pci port needs to be rebind to eliminate "/dev/vfio/X Permission denied" error

If a vfio-pci port gets bind before OVS gets installed, the daemon will report "Cannot open /dev/vfio/X: Permission denied" ERR when OVS is started.

This RFE bug request for rebinding of such an used port to eliminate such en error.

Version-Release number of selected component (if applicable):
[root@netqe22 openvswitch]# rpm -q openvswitch
openvswitch-2.9.0-15.el7fdp.x86_64
[root@netqe22 openvswitch]# uname -a
Linux netqe22.knqe.lab.eng.bos.redhat.com 3.10.0-862.el7.bz1558328.x86_64 #1 SMP Thu Mar 22 11:10:59 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux

How reproducible: Reproducible


Steps to Reproduce:
1. Bind a vfio-pci port before OVS installation; Should see
ll /dev/vfio
total 0
crw-------. 1 root root 239,   0 Apr 15 14:44 18
 
2. Install OVS
3. start OVS; Should see the Permission denied error.

Actual results:


Expected results:


Additional info:

Comment 5 Aaron Conole 2018-09-11 14:40:09 UTC
There isn't a good way to solve this.  The issue is that the udev rules come with openvswitch to setup vfio devices accordingly.  Without openvswitch package, there's nothing sane we can do.  Closing as WONTFIX - if you figure out a better way of realizing this feature, feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.