Bug 1567879 - UI do not ask for a relogin, after network disconnection, and thus running operations, have no response.
Summary: UI do not ask for a relogin, after network disconnection, and thus running op...
Keywords:
Status: CLOSED DUPLICATE of bug 1512525
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.8.4
Assignee: Martin Hradil
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-16 10:33 UTC by Ilanit Stein
Modified: 2018-04-16 14:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 14:24:40 UTC
Category: Bug
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
evm.log (4.03 MB, application/x-gzip)
2018-04-16 10:35 UTC, Ilanit Stein
no flags Details
automation.log (152.45 KB, application/x-gzip)
2018-04-16 10:35 UTC, Ilanit Stein
no flags Details
production.log (83.51 KB, application/x-gzip)
2018-04-16 10:36 UTC, Ilanit Stein
no flags Details

Description Ilanit Stein 2018-04-16 10:33:43 UTC
Description of problem:
I had a Chrome connected to CFME admin UI on my laptop. 
I disconnected from the network and then connected back.
The UI didn't ask for a login renewal.
I entered a VM snapshot menu, and tried twice to run create a snapshot - nothing happen. 
then I tried again, and sew endless rotating spinner.
automation.log showed the create events are unknown.

I then went out of the menu back to the VMs page, 
and CFME UI asked for login.
Now I could create a snapshot successfully.

Version-Release number of selected component (if applicable):
CFME-5.7.4.3
RHV-4.2.2-5

How reproducible:
I didn't manage to reproduce this yet.


Additional info:
Automation.log part with the unknown create event response.
[----] I, [2018-04-16T03:09:52.572825 #38323:114f108]  INFO -- : MIQ(MiqPriorityWorker::Runner#get_message_via_drb) Message id: [87683], MiqWorker id: [3], Zo
ne: [default], Role: [automate], Server: [], Ident: [generic], Target id: [], Instance id: [], Task id: [], Command: [MiqAeEngine.deliver], Timeout: [3600], P
riority: [20], State: [dequeue], Deliver On: [], Data: [], Args: [{:object_type=>"EmsEvent", :object_id=>4255, :attrs=>{:event_id=>4255, :event_stream_id=>425
5, :event_type=>"UNKNOWN", "Host::host"=>2, :host_id=>2}, :instance_name=>"Event", :user_id=>1, :miq_group_id=>1, :tenant_id=>1, :automate_message=>nil}], Deq
ueued in: [4.29523382] seconds
[----] I, [2018-04-16T03:09:52.573010 #38323:114f108]  INFO -- : MIQ(MiqQueue#deliver) Message id: [87683], Delivering...
[----] I, [2018-04-16T03:09:52.577811 #38323:114f108]  INFO -- : <AutomationEngine> User [admin] with current group ID [1] name [Tenant My Company access]
[----] I, [2018-04-16T03:09:52.578042 #38323:114f108]  INFO -- : MIQ(MiqAeEngine.deliver) Delivering {:event_id=>4255, :event_stream_id=>4255, :event_type=>"U
NKNOWN", "Host::host"=>2, :host_id=>2} for object [EmsEvent.4255] with state [] to Automate
[----] I, [2018-04-16T03:09:52.581700 #38323:114f108]  INFO -- : <AutomationEngine> Instantiating [/System/Process/Event?EventStream%3A%3Aevent_stream=4255&Ho
st%3A%3Ahost=2&MiqServer%3A%3Amiq_server=1&User%3A%3Auser=1&event_id=4255&event_stream_id=4255&event_type=UNKNOWN&host_id=2&object_name=Event&vmdb_object_type
=event_stream]
[----] I, [2018-04-16T03:09:52.619248 #38323:114f108]  INFO -- : <AutomationEngine> Updated namespace [/System/Process/Event?EventStream%3A%3Aevent_stream=425
5&Host%3A%3Ahost=2&MiqServer%3A%3Amiq_server=1&User%3A%3Auser=1&event_id=4255&event_stream_id=4255&event_type=UNKNOWN&host_id=2&object_name=Event&vmdb_object_
type=event_stream  ManageIQ/System]
[----] I, [2018-04-16T03:09:52.683139 #38323:114f108]  INFO -- : <AutomationEngine> Following Relationship [miqaedb:/System/Event/EmsEvent/RHEVM/UNKNOWN#creat
e]
[----] I, [2018-04-16T03:09:52.720732 #38323:114f108]  INFO -- : <AutomationEngine> Updated namespace [miqaedb:/System/Event/EmsEvent/RHEVM/UNKNOWN#create  Ma
nageIQ/System/Event/EmsEvent]
[----] I, [2018-04-16T03:09:52.777857 #38323:114f108]  INFO -- : <AutomationEngine> Instance [/ManageIQ/System/Event/EmsEvent/RHEVM/UNKNOWN] not found in MiqA
eDatastore - trying [.missing]
[----] I, [2018-04-16T03:09:52.793054 #38323:114f108]  INFO -- : <AutomationEngine> Followed  Relationship [miqaedb:/System/Event/EmsEvent/RHEVM/UNKNOWN#create]

Note:
This might be related to bug 1567233.

Comment 2 Ilanit Stein 2018-04-16 10:35:32 UTC
Created attachment 1422400 [details]
evm.log

Comment 3 Ilanit Stein 2018-04-16 10:35:56 UTC
Created attachment 1422401 [details]
automation.log

Comment 4 Ilanit Stein 2018-04-16 10:36:27 UTC
Created attachment 1422403 [details]
production.log

Comment 7 Martin Hradil 2018-04-16 14:24:40 UTC

*** This bug has been marked as a duplicate of bug 1512525 ***


Note You need to log in before you can comment on or make changes to this bug.