Bug 156788 - calling glXGetConfig with i915 crashes
calling glXGetConfig with i915 crashes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-04 05:41 EDT by Fridrich Strba
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fridrich Strba 2005-05-04 05:41:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
The test program from bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139712
Crashes the above-mentioned xorg-x11 on Enterprise Linux 4

The trace is here:
0x005d2ab5 in free () from /lib/tls/libc.so.6
(gdb) where
#0  0x005d2ab5 in free () from /lib/tls/libc.so.6
#1  0x0038c6a7 in __driUtilCreateScreen ()
   from /usr/X11R6/lib/modules/dri/i915_dri.so
#2  0x003a4af5 in __driCreateScreen ()
   from /usr/X11R6/lib/modules/dri/i915_dri.so
#3  0x070b36a2 in __glXInitialize () from /usr/X11R6/lib/libGL.so.1
#4  0x070af3db in __indirect_glCompressedTexSubImage3D ()
   from /usr/X11R6/lib/libGL.so.1
#5  0x070b0453 in glXGetConfig () from /usr/X11R6/lib/libGL.so.1
#6  0x0804863a in main ()

I am compiling xorg-x11-6.8.2-1.FC3.13 to see whether the problem will be solved.



Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-23.EL

How reproducible:
Always

Steps to Reproduce:
1. run the test program from https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139712
2. crash
3.
  

Actual Results:  application is crashing

Expected Results:  Application is not crashing

Additional info:
Comment 2 Mike A. Harris 2005-05-13 17:34:31 EDT
This is fixed in xorg-x11-6.8.2 already, which will be in RHEL4 U1.  There
are test packages available currently for download at:

    ftp://people.redhat.com/mharris/testing/4E/xorg-x11/6.8.2-1.EL.13.5

Please test these packages out, and if the problem persists, log into
the Red Hat Global Support Services website at http://www.redhat.com/support
or call 1-888-RED-HAT1 to open a support ticket for official Red Hat
Enterprise Linux support.

Setting status to "MODIFIED".
Comment 3 Fridrich Strba 2005-05-14 08:03:11 EDT
The problem looks actually like solved in 6.8.2. I roled packages from the SRPM
from fedora core 3 updates testing and the crash does not appear anymore. It
looks like the fix is to detect hardware that creates problems and fall back to
the indirect (slow) rendering. At least console messages say this. I would
consider it closed since the 6.8.2-1.EL.13.5 (that I cannot access because the
ftp server asks me to authenticate :-)) and the version from fedora core 3
updates testing are likely to be very similar
Comment 4 Mike A. Harris 2005-05-14 14:17:50 EDT
The xorg-x11 rpms are include and enable a different set of patches
for FC3/FC4/RHEL4.  If the base 6.8.2 release contains a fix for
bugs in 6.8.1 or earlier, using any of our 6.8.2 builds will likely
solve a given issue.  If an issue is fixed by a patch we apply
however, it may or may not be applied to specific builds.

As such, we need RHEL customers to test official RHEL builds for
bug fixes, as they're not the same as Fedora Core builds.

The 6.8.2-1.EL.13.5 rpms linked to above are publically accessible
via standard anonymous ftp, which I've just confirmed this myself.
Just to be sure there's no problem with external access, two people
in IRC confirmed the files are downloadable as well.  If you're
having firewall problems, enabling or disabling "passive" mode
in your ftp client often works around them.

Hope this helps.
Comment 5 Fridrich Strba 2005-05-15 01:28:17 EDT
Sorry, my fault with the FTP.
I installed the packages and everything is OK. testgl finishes without crashing
and other applications (as openoffice.org-1.9.100-1, a RHEL4 version of FC4
packages, built with gcc/g++ 3.4 and gcj4/gij4 4.0.0-5) work very well.

Note You need to log in before you can comment on or make changes to this bug.