Bug 1568261 - Login on WebUI fails for IPA user if IPA server is installed with 0027 as root umask.
Summary: Login on WebUI fails for IPA user if IPA server is installed with 0027 as roo...
Keywords:
Status: CLOSED DUPLICATE of bug 1485217
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 04:45 UTC by Abhinay Reddy Peddireddy
Modified: 2018-04-19 09:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 09:50:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Abhinay Reddy Peddireddy 2018-04-17 04:45:34 UTC
Description of problem:

Accessing WebUI fails if IPA server is installed with  0027 as root umask. 

It throws the error "Login failed due to an unknown reason". 



Version-Release number of selected component (if applicable):

RHEL 7.4 

IPA version : ipa-server-4.5.0-22.el7_4.x86_64 



Steps to Reproduce:

- Install a fresh RHEL 7.4 machine. 

- Set umask of root to 0027. 

- Install required IPA packages and then perform IPA server installation. 

- I see the permissions on below files are : 

[root@rhel7u4 ~]# ll /etc/ipa/ca.crt 
-rw-r----- 1 root root 1307 Apr  6 04:20 /etc/ipa/ca.crt
[root@rhel7u4 ~]# ll  /etc/pki/ca-trust/source/ipa.p11-kit
-rw-r----- 1 root root 3613 Apr  6 04:25 /etc/pki/ca-trust/source/ipa.p11-kit
[root@rhel7u4 ~]# ll /var/lib/ipa-client/pki/ca-bundle.pem
-rw-r----- 1 root root 1307 Apr  6 04:25 /var/lib/ipa-client/pki/ca-bundle.pem
[root@rhel7u4 ~]# ll /var/lib/ipa-client/pki/kdc-ca-bundle.pem
-rw-r----- 1 root root 1307 Apr  6 04:25 /var/lib/ipa-client/pki/kdc-ca-bundle.pem

We can access the WebUI at this point but login as admin user, fails with an error message  "Login failed due to an unknown reason". 

- Then tried to set 644 permissions on the files mentioned above. 

- And login works now appropriately.



Additional info:


- Similar to the issue described in bug #1448697


- Trust module also disabled : 

# modutil -dbdir /etc/httpd/alias -list "Root Certs"

-----------------------------------------------------------
Name: Root Certs
Library file: /etc/httpd/alias/libnssckbi.so
Manufacturer: PKCS#11 Kit
Description: PKCS#11 Kit Trust Module
PKCS #11 Version 2.40
Library Version: 0.23
Cipher Enable Flags: None
Default Mechanism Flags: None

  Slot: /etc/pki/ca-trust/source
  Slot Mechanism Flags: None
  Manufacturer: PKCS#11 Kit
  Type: Software
  Version Number: 0.23
  Firmware Version: 0.0
  Status: DISABLED (user disabled)
  Token Name: System Trust
  Token Manufacturer: PKCS#11 Kit
  Token Model: p11-kit-trust
  Token Serial Number: 1
  Token Version: 0.23
  Token Firmware Version: 0.0
  Access: NOT Write Protected
  Login Type: Public (no login required)
  User Pin: NOT Initialized

  Slot: /usr/share/pki/ca-trust-source
  Slot Mechanism Flags: None
  Manufacturer: PKCS#11 Kit
  Type: Software
  Version Number: 0.23
  Firmware Version: 0.0
  Status: DISABLED (user disabled)
  Token Name: Default Trust
  Token Manufacturer: PKCS#11 Kit
  Token Model: p11-kit-trust
  Token Serial Number: 1
  Token Version: 0.23
  Token Firmware Version: 0.0
  Access: NOT Write Protected
  Login Type: Public (no login required)
  User Pin: NOT Initialized

Comment 2 Standa Laznicka 2018-04-19 09:50:50 UTC
This is a duplicate of an RFE Bugzilla.

*** This bug has been marked as a duplicate of bug 1485217 ***


Note You need to log in before you can comment on or make changes to this bug.