Bug 156830 - building kernel is not successfull during linking stage
building kernel is not successfull during linking stage
Status: CLOSED DUPLICATE of bug 156827
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-04 11:36 EDT by Alexander Suvorov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 15:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix definition of page_is_ram() function (344 bytes, patch)
2005-05-04 11:38 EDT, Alexander Suvorov
no flags Details | Diff

  None (edit)
Description Alexander Suvorov 2005-05-04 11:36:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
There is a little bug in kernel sources that prevents to build kernel successfully with enabling crash module ().

I test only i386 platform, but probably it exists on x86_64 and mips platforms because of identical definition of page_is_ram function.



Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.3.EL.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. enable crash as module or built-in
2. run make 
3. got error message
  

Actual Results:  ...
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o(.text+0x4cc4d): In function `crash_read':
include/asm/crash.h:42: undefined reference to `page_is_ram'
make: *** [.tmp_vmlinux1] Error 1

Expected Results:  linking ok


Additional info:

I attached a little patch to fix this bug
Comment 1 Alexander Suvorov 2005-05-04 11:38:11 EDT
Created attachment 114021 [details]
patch to fix definition of page_is_ram() function
Comment 2 Suzanne Hillman 2005-05-04 15:59:11 EDT

*** This bug has been marked as a duplicate of 156827 ***

Note You need to log in before you can comment on or make changes to this bug.