Bug 1568342 - SUI - While ordering service catalog, the dynamic drop-down dialogs fields do not auto-refreshed.
Summary: SUI - While ordering service catalog, the dynamic drop-down dialogs fields do...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.2
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 09:49 UTC by Imaan
Modified: 2018-06-06 17:59 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 20:28:15 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
dialog (3.58 KB, text/x-vhdl)
2018-04-17 17:51 UTC, Shveta
no flags Details
domain (4.82 KB, application/zip)
2018-04-17 17:52 UTC, Shveta
no flags Details
5.9.2 video (2.08 MB, application/octet-stream)
2018-04-20 17:57 UTC, Shveta
no flags Details

Description Imaan 2018-04-17 09:49:29 UTC
Description of problem:

While ordering service catalog, the dynamic drop-down dialogs fields do not auto-refreshed. 

Version-Release number of selected component (if applicable):

5.9.1.2.20180321221247_67fd99d

How reproducible:

Always

Steps to Reproduce:

1. Create a dialog with a static dropdown as field 1

2. Create one more field with a dynamic drop down that points to a method to load the values on it, depending on the option selected in field 1.

3. Field 1 must refresh field 2 when it is modified.

4. Create a catalog and catalog item using the dialog.

5. Try to order the service.


Actual results:

The dialog and the values of both fields are loaded correctly the first time.             Issue: When modifying field1 the field2 does not change or auto-refreshed.

Expected results:

It should be auto-refreshed.

Comment 3 Shveta 2018-04-17 17:51:59 UTC
Created attachment 1423197 [details]
dialog

Hi , 
I have a similar dialog with one static dropdown and based on the value selected in first dropdown , second dropdown auto-refreshes.
It seems to be loading values fine at the second time .
Can you please check with the attached dialog and domain

Comment 4 Shveta 2018-04-17 17:52:52 UTC
Created attachment 1423198 [details]
domain

Appliance : https://10.8.197.179/
Servie :generic
Version : 5.9.1.2.20180321221247_67fd99d

Comment 12 Shveta 2018-04-20 17:57:23 UTC
Created attachment 1424633 [details]
5.9.2 video

Unable to recreate on 5.9.2 .Please check video .
Values are loaded everytime a value is selected in first dropdown.
Appliance : https://10.8.198.94/ui/service/
Service - generic

Comment 14 Tina Fitzgerald 2018-04-20 20:07:49 UTC
Hi Felix,

Could you also ask the customer to supply the evm.log as well.

Thanks,
Tina


Note You need to log in before you can comment on or make changes to this bug.