Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1568363 - False warnings alert about "unused parameters" even though they are used
Summary: False warnings alert about "unused parameters" even though they are used
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 11:05 UTC by Udi
Modified: 2019-09-05 19:42 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 19:42:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1842754 0 None None None 2019-09-05 19:12:31 UTC

Description Udi 2018-04-17 11:05:30 UTC
Description of problem:
When deploying with SSL you see this warning in the beginning of the deployment:

WARNING: Following parameters are defined but not used in plan. Could be possible that parameter is valid but currently not used.
  SSLKey
  SSLIntermediateCertificate
  SSLRootCertificate

The deploy command I used: 
openstack overcloud deploy --templates --ntp-server clock.redhat.com -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/ssl/enable-tls.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/ssl/inject-trust-anchor.yaml -e custom.yaml

Doing "openstack stack environment show overcloud" shows that the appropriate override is in the resource registry:

  OS::TripleO::NodeTLSData: https://192.168.24.2:13808/v1/AUTH_d89c3add038047b0b4bedc6bebe43c87/overcloud/puppet/extraconfig/tls/tls-cert-inject.yaml
  OS::TripleO::NodeTLSCAData: https://192.168.24.2:13808/v1/AUTH_d89c3add038047b0b4bedc6bebe43c87/overcloud/puppet/extraconfig/tls/ca-inject.yaml

which should use the parameters. Downloading "https://192.168.24.2:13808/v1/AUTH_d89c3add038047b0b4bedc6bebe43c87/overcloud/puppet/extraconfig/tls/tls-cert-inject.yaml" from swift shows the correct file.


Version-Release number of selected component (if applicable):
openstack-tripleo-common-8.5.1-0.20180326153322.91f52e9.el7ost.noarch
openstack-heat-common-10.0.1-0.20180314232330.c2a66b1.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Deploy an overcloud with SSL like in the above description


Actual results:
A warning appears in the beginning of the deployment

Comment 2 Juan Antonio Osorio 2018-05-14 11:06:29 UTC
I'm actually not sure how to address this nor what's going on. The parameters should be in the plan, as they're passed as part of the environment files, and as part of those environment files is also de registry override that defines the resource that takes them into use.

Comment 6 Alex Schultz 2019-09-05 19:42:57 UTC
We're going to do some filtering on these vars to reduce the ones that get printed out because they are generated by us (e.g. Docker*Image vars). This is mostly here for the end user to reference if they end up having issues with with some setting being applied. I've posted an upstream bug around this where the status can be tracked and proposed a patch to update the text a bit more to indicate this situation.


Note You need to log in before you can comment on or make changes to this bug.