Bug 156848 - OOo gcj fails due to stale config reference to libgcj_fc4.so.6
OOo gcj fails due to stale config reference to libgcj_fc4.so.6
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-04 13:30 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-10 06:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-05-04 13:30:47 EDT
On PPC, 1.9.100-1 seems to be looking for /usr/lib/libgcj_fc4.so.6 instead of
/usr/lib/libgcj.so.6 and hence all use of Java fails. A symlink makes it happy.
I am unable to select /usr/lib/libgcj.so.6 from the configuration thingy for Java.
Comment 1 Caolan McNamara 2005-05-04 13:53:34 EDT
! wierd, because back when there was a libgcj_fc4.so.6 instead of libgcj.so.6 I
had OOo patched to do that. But there is no such patch now in the spec, nor was
that upstreamed. So there's no code which references libgcj_fc4.so.6 in OOo.

Hmm... perhaps attach your
~/openoffice.org2.0/user/config/javasettings_Linux_*.xml file here, then rm it
and restart OOo.
Comment 2 Caolan McNamara 2005-05-04 13:55:38 EDT
There should be no reason to touch the configuration thing for java unless
debugging, or there are more than one javas installed and one is to be preferred
over the other.
Comment 3 David Woodhouse 2005-05-05 06:12:17 EDT
<vendorData>00660069006C0065003A002F002F002F007500730072002F006C00690062002F006C0069006200670063006A005F006600630034002E0073006F002E0036</vendorData>
i.e. file:///usr/lib/libgcj_fc4.so.6

Removing it and restarting OOo makes it all happy again.
Comment 4 Caolan McNamara 2005-05-30 04:43:07 EDT
So would only affect someone who has ran the old ooo 1.9 previews which knew
about libgcj_fc4
Comment 5 Caolan McNamara 2005-06-10 06:31:11 EDT
ah realistically I'm not going to go track this one down, only arose because of
the short-term hack to get ooo working when libgcj_fc4.so.6 was in existance

Note You need to log in before you can comment on or make changes to this bug.