Bug 156859 - sundance driver missing pci id.
sundance driver missing pci id.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-04 14:57 EDT by SiuPhen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 11:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (280.44 KB, application/octet-stream)
2005-08-21 14:46 EDT, SiuPhen
no flags Details
jwltest-sundance-fixes.patch (968 bytes, patch)
2005-09-09 13:07 EDT, John W. Linville
no flags Details | Diff

  None (edit)
Description SiuPhen 2005-05-04 14:57:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Downloaded a network driver from http://www.icplus.com.tw/driver-pp-IP100A.html for my ABit NF7-S2.  When trying to compile the driver, it complained invalid struct member pci_dev->slot_name.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download driver for IC+ IP100A from http://www.icplus.com.tw/driver-pp-IP100A.html
2. extract files
3. type "make all"
  

Actual Results:  Compilation failed due to invalid struct member pci_dev->slot_name.

Expected Results:  Sucessful compilation of source files.

Additional info:
Comment 1 Dave Jones 2005-05-06 15:14:59 EDT
this driver needs fixing. Its based on an earlier version of the sundance driver
from the kernel. Looking a diff between the two, the only real change of
significance seems to be the addition of a PCI ID.
I've created a patch to add this to the kernel, I'll get it in the next build
that appears at 
http://people.redhat.com/davej/kernels/Fedora/FC4/RPMS.kernel/

(ie, later than rev 1257).

This is too late for FC3 test3, but it should make it into the final release.
Then you won't need this vendor module, and will just be able to use the one
that the kernel provides.
Comment 2 Dave Jones 2005-05-06 15:27:22 EDT
that should have been 'later than rev 1287'.
Comment 3 Dave Jones 2005-05-23 19:28:11 EDT
Can you test with the latest kernel at
http://people.redhat.com/davej/kernels/Fedora/FC4/ and double-check that it works ?
Comment 4 SiuPhen 2005-06-20 14:58:49 EDT
I've installed the final version of FC4 and still couldn't get the network 
card working.  The kernel can now see the Sundance network card but not able 
to identify it any further.  In the network configuration window, it shows: 

Sundance Technology Inc: Unknown device 0200 (eth1)

When I tried to manually configure and activate it, it returns the following 
error:

sundance device eth1 does not seem to be present, delaying initialization.

Comment 5 Dave Jones 2005-06-27 19:23:04 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 6 John W. Linville 2005-07-08 10:39:32 EDT
Please attach the output of running "sysreport"...thanks! 
Comment 7 Dave Jones 2005-07-15 17:14:48 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 8 SiuPhen 2005-08-21 14:46:02 EDT
Created attachment 117955 [details]
sysreport

I installed 2.6.12-1.1398_FC4 update but still got the same error message:

sundance device eth1 does not seem to be present, delaying initialization

I have attached the sysreport for your information.

Many Thanks!
Comment 9 John W. Linville 2005-08-22 16:12:56 EDT
As Dave pointed-out, the driver changes published for this device are very 
minor and are already incorporated in the FC4 sources.  Is it at all possible 
that your sundance device is malfunctioning? 
Comment 10 SiuPhen 2005-08-24 01:02:58 EDT
It's possible but not very likely since my machine is configured as a dual-
boot system and the device is working fine under Windows XP.  May be I will 
install a new NIC.
Comment 11 John W. Linville 2005-08-25 16:45:37 EDT
I have pulled-in (a slightly modified to make it work) version of the Sundance  
driver from ICPlus (from the URL in the bug report).  It is available as the  
"sundance-icplus" driver available here:  
  
   http://people.redhat.com/linville/kernels/fc4/  
  
Please do the following:  
  
   -- install the appropriate kernel from the URL above; 
   -- edit /etc/modprobe.conf to change all instances of "sundance" to 
      "sundance-icplus"; and, 
   -- reboot and test your sundance device. 
 
I'd like to know what your results are of using the "sundance-icplus" driver.  
If it works, maybe we can dig-out some elusive difference between it and the 
upstream driver. 
 
Please post your results here...thanks! 
Comment 12 SiuPhen 2005-09-03 02:16:35 EDT
Hello John,

Good news.  The NIC is working now after following your instructions mentioned 
above.  However, one thing I noticed is that I need to manually modify 
the /etc/modprobe.conf file everytime I changed the network setting.  Anyway, 
it works fine on my installation now.

Many Thanks!
Comment 13 John W. Linville 2005-09-06 11:25:22 EDT
Unfortunately, I cannot accept that driver into Fedora's kernel.  ICplus would 
have to get their changes accepted in the public kernel sources first. 
 
I will investigate further to determine what non-obvious changes may be in 
that version of the driver which might be making things work. 
Comment 14 John W. Linville 2005-09-09 13:07:48 EDT
Created attachment 118647 [details]
jwltest-sundance-fixes.patch

A few promising fixes from the vendor-provided driver...
Comment 15 John W. Linville 2005-09-09 13:10:49 EDT
Test kernels w/ the above patch available here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please _UNDO_ the changes to modprobe.conf from comment 11 and try these 
kernels.  Please post the results here...thanks! 
Comment 16 John W. Linville 2005-10-07 16:10:45 EDT
I could really use some feedback.  Otherwise, your sundance card is going to 
quit working w/ FC5... 
Comment 17 Joao Meidanis 2005-10-18 10:29:03 EDT
I'm not Siu Phen but I guess I can provide some positive feedback in this case.

I bought an Encore 10/100 NIC and was trying to use it as the second network
interface on my new home PC, doing IP masquerade for the old PC.  I installed
Fedora 4 on the new machine, but it didn't automatically recognize the second
network card.  With kernel-2.6.13-1.1528_FC4.jwltest.20.i686.rpm from the link
on Comment #16, the card was recognized and worked fine.  I was able to setup
both machines so that the new one is connected to my internet provider, and the
old one has access to the internet via IP masquerade.

I wish to thank John Linville and hope this feedback helps you guys keeping up
with the good work on Fedora.
(In reply to comment #16)
> I could really use some feedback.  Otherwise, your sundance card is going to 
> quit working w/ FC5... 

(In reply to comment #16)
> I could really use some feedback.  Otherwise, your sundance card is going to 
> quit working w/ FC5... 

(In reply to comment #11)
> I have pulled-in (a slightly modified to make it work) version of the Sundance  
> driver from ICPlus (from the URL in the bug report).  It is available as the  
> "sundance-icplus" driver available here:  
>   
>    http://people.redhat.com/linville/kernels/fc4/  
>   
> Please do the following:  
>   
>    -- install the appropriate kernel from the URL above; 
>    -- edit /etc/modprobe.conf to change all instances of "sundance" to 
>       "sundance-icplus"; and, 
>    -- reboot and test your sundance device. 
>  
> I'd like to know what your results are of using the "sundance-icplus" driver.  
> If it works, maybe we can dig-out some elusive difference between it and the 
> upstream driver. 
>  
> Please post your results here...thanks! 

Comment 18 John W. Linville 2005-10-18 10:34:34 EDT
Joao, 
 
Just to clarify, are you using the "sundance" driver?  Or did you change to 
using the "sundance-icplus" driver?  As stated in comment 13, I cannot accept 
"sundance-icplus" into Fedora.  But, if my modifications to the "sundance" 
driver are working for you then that is good news. 
 
Please confirm that you are using the "sundance" driver from my test 
kernels...thanks! 
Comment 19 Joao Meidanis 2005-10-22 14:18:37 EDT
I believe I'm using the "sundance" driver, because I didn't edit
/etc/modprobe.conf at all.  I just downloaded the kernel, installed it and the
card worked on the next boot.

I still have a problem: eth1 will work only when activated before eth0, whereas
on boot time they are activated in the order eth0, eth1.  I'm not sure this is
related to the driver, though.  (eth0 is an Intel 82801 Ethernet Controller;
eth1 is the Sundance-like card).
Comment 20 John W. Linville 2005-10-24 11:57:28 EDT
I have posted the sundance patches upstream.  They should filter into Fedora 
eventually. 
 
If you continue to experience the other issue (order of activation), please 
open a separate bugzilla for that one...thanks! 

Note You need to log in before you can comment on or make changes to this bug.