Bug 1568597 - mutt says mailbox is read-only
Summary: mutt says mailbox is read-only
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matej Mužila
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 21:29 UTC by Paul Sand
Modified: 2018-05-12 18:18 UTC (History)
7 users (show)

Fixed In Version: mutt-1.9.5-4.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-12 18:18:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Sand 2018-04-17 21:29:46 UTC
Description of problem:

Attempting to delete messages from normal-user mailbox in mutt says "mailbox is read-only"

Version-Release number of selected component (if applicable):

mutt-1.9.5-2.fc28.x86_64

How reproducible:

Attempt to delete message in mutt.

Steps to Reproduce:
1. run mutt
2. display message in /var/spool/mail mailbox
3. press "d".

Actual results:

Message "Mailbox is read-only". Message not deleted.

Expected results:

Message should be deleted.

Additional info:

Seems to be related to the upgrade (this morning) to mutt-1.9.5. 

Deleting the message in "mailx" works fine.

Comment 1 Matej Mužila 2018-04-18 11:48:39 UTC
Hi,

thank you for submitting your bug report. I'm going to look at it.

Comment 2 Matej Mužila 2018-04-18 15:59:47 UTC
Hi,

the problem seems to be that USE_DOTLOCK became enabled in this release.

Could you please test the fix [1] ?





[1] https://kojipkgs.fedoraproject.org//work/tasks/2943/26442943/mutt-1.9.5-4.fc28.x86_64.rpm
[2] https://koji.fedoraproject.org/koji/taskinfo?taskID=26442942

Comment 3 Paul Sand 2018-04-18 18:15:15 UTC
Matej: yes, the RPM you provided does fix the behavior I described. Thank you.

Additional: I notice the man page for mutt mentions /usr/bin/mutt_dotlock, describing it as "The privileged dotlocking program". This is not in the RPM (either new or old). I haven't researched this further.

Comment 4 Matej Mužila 2018-04-19 12:33:56 UTC
Thank  you.

The mutt_dotlock is not shipped in fedora. We probably should patch the man page to reflect this fact.

Comment 5 Fedora Update System 2018-04-19 12:45:37 UTC
mutt-1.9.5-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-78e750b56f

Comment 6 Fedora Update System 2018-04-20 01:48:57 UTC
mutt-1.9.5-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-78e750b56f

Comment 7 Fedora Update System 2018-05-12 18:18:56 UTC
mutt-1.9.5-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.