Bug 15686 - exportfs puts entries into etab in random order.
Summary: exportfs puts entries into etab in random order.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-07 22:21 UTC by Aleksey Nogin
Modified: 2007-04-18 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-24 17:55:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2000-08-07 22:21:05 UTC
I have the following entry in my /etc/exports :

/some/file/system	cluster*.mydomain.edu(no_root_squash,ro)
*.mydomain.edu(ro)

Sometimes exportfs would put the no_root_squash entry before the other one
in the /var/lib/nfs/etab and in that case evrything would work correctly,
but in other cases (I could not find out what it depends on, it seems that
changing other lines of /etc/exports randomly affect this) it would put the
no_root_squash entry second and in that case it never gets used (since the
other entry will always match), which is really painful.

So far the only solution I was able to come up with is to remove the second
entry from the /etc/exports for now, but I believe that exportfs should be
fixed to always put entries into the etab in the same order they appear in
/etc/exports.

P.S. Are the NIS netgroups supposed to be supported by nfs-utils-0.1.9.1-1?
I couldn't get that to work, but if it is supposed to work, I will try
again and try to understand what exactly happens.

Comment 1 Cristian Gafton 2000-08-09 02:35:44 UTC
assigned to johnsonm

Comment 2 Aleksey Nogin 2001-05-21 15:15:16 UTC
Jason, have you tried this in 7.1 yet, does 7.1 have the same problem?

Comment 3 thoth 2002-02-06 21:18:20 UTC
See bug 10332 about NFS supporting netgroups in /etc/exports.

Comment 4 Steve Dickson 2002-12-24 17:55:32 UTC
This is not reproduceable in the latest release


Note You need to log in before you can comment on or make changes to this bug.