Bug 1569020 - EC2 All Cloud Volumes view is broken when when navigated from block volume manager relationships
Summary: EC2 All Cloud Volumes view is broken when when navigated from block volume ma...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:storage:ec2:volume
Depends On:
Blocks: 1570051
TreeView+ depends on / blocked
 
Reported: 2018-04-18 14:00 UTC by Matouš Mojžíš
Modified: 2019-02-11 14:01 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1570051 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:01:26 UTC
Category: ---
Cloudforms Team: AWS
Target Upstream Version:


Attachments (Terms of Use)
production.log stacktrace (12.07 KB, text/plain)
2018-04-18 14:00 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2018-04-18 14:00:28 UTC
Created attachment 1423588 [details]
production.log stacktrace

Description of problem:
Can't reproduce this issue on 5.9.0.22

Version-Release number of selected component (if applicable):
5.9.2.2

How reproducible:
Always

Steps to Reproduce:
1. Add an ec2 provider
2. Create a volume
3. Go to Storage -> Block Storage -> EC2 block storage manager -> Volumes

Actual results:
Exception - production.log stacktrace attached

Expected results:


Additional info:

Comment 4 Bronagh Sorota 2018-04-19 08:05:57 UTC
Hi Matous,
Can you please attach the evm.log?

Thanks
Bronagh

Comment 5 Bronagh Sorota 2018-04-19 14:18:56 UTC
Dan
Can you prioritize this, it is a 5.9.2 blocker.

Thanks
Bronagh

Comment 7 CFME Bot 2018-04-20 09:18:50 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/eb4b8c14ccf43678f3eea784d877c1f63ca4ff36
commit eb4b8c14ccf43678f3eea784d877c1f63ca4ff36
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Apr 19 14:51:34 2018 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Apr 19 14:51:34 2018 -0400

    Added setting of `@ems` to fix the nilclass error.

    Issue was introduced in https://github.com/ManageIQ/manageiq-ui-classic/pull/3341

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1569020

 app/controllers/ems_storage_controller.rb | 2 +-
 spec/controllers/ems_storage_controller_spec.rb | 10 +
 spec/views/shared/views/ems_common/_show.html.haml_spec.rb | 20 +
 3 files changed, 31 insertions(+), 1 deletion(-)

Comment 9 Matouš Mojžíš 2018-07-24 14:07:39 UTC
Verified in 5.10.0.4. Volumes can be accessed from block volume manager relationships.


Note You need to log in before you can comment on or make changes to this bug.