Bug 1569073 - Udisks2 obsoletes storaged but does not provide a replacement
Summary: Udisks2 obsoletes storaged but does not provide a replacement
Keywords:
Status: CLOSED DUPLICATE of bug 1527320
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: udisks2
Version: 7.4
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Vojtech Trefny
QA Contact: xhe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 14:54 UTC by Kurt Hey
Modified: 2018-04-19 07:11 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 07:11:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1527320 1 None None None 2021-01-20 06:05:38 UTC

Internal Links: 1527320

Description Kurt Hey 2018-04-18 14:54:30 UTC
Description of problem:
After customizing the overcloud image of OSP-10 using RHEL 7.4 and then running the overcloud_deploy.sh we have, rhscon-agent fails to install on the overcloud due to storaged being obsoleted by udisks2.  

Per Mike Burns:

So the issue a bug in udisks2.  It obsoletes storaged but doesn't provide storaged.

When obsoleting a package, there should be:

Obsoletes:  <package>
Provides:  <package>

In this case, udisks2 only did the Obsoletes entry so anything that requires "storaged" will fail to install.

This should be filed as a RHEL 7 bug against udisks2.


Version-Release number of selected component (if applicable):

udisks2.x86_64 0:2.7.3-6.el7

How reproducible:

Always

Steps to Reproduce:
1. Install Dell EMC JS-10.1 OSP 10 bits
2.
3.

Actual results:

Error: Package: rhscon-agent-0.0.19-1.el7scon.noarch (rhel-7-server-rhscon-2-agent-rpms)
           Requires: storaged-lvm2
           Available: storaged-lvm2-2.2.0-2.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged-lvm2 = 2.2.0-2.el7
           Available: storaged-lvm2-2.2.0-3.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged-lvm2 = 2.2.0-3.el7
           Available: storaged-lvm2-2.5.2-2.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged-lvm2 = 2.5.2-2.el7
           Available: storaged-lvm2-2.5.2-3.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged-lvm2 = 2.5.2-3.el7
           Available: storaged-lvm2-2.5.2-4.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged-lvm2 = 2.5.2-4.el7
Error: Package: rhscon-agent-0.0.19-1.el7scon.noarch (rhel-7-server-rhscon-2-agent-rpms)
           Requires: storaged
           Available: storaged-2.2.0-2.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged = 2.2.0-2.el7
           Available: storaged-2.2.0-3.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged = 2.2.0-3.el7
           Available: storaged-2.5.2-2.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged = 2.5.2-2.el7
           Available: storaged-2.5.2-3.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged = 2.5.2-3.el7
           Available: storaged-2.5.2-4.el7.x86_64 (rhel-7-server-extras-rpms)
               storaged = 2.5.2-4.el7


Expected results:


Additional info:

Comment 3 Vojtech Trefny 2018-04-19 07:09:42 UTC
This is actually intentional. UDisks replaces Storaged, but doesn't provide the same API storaged provides, so we can't add "Provides: storaged" for udisks2 package. rhscon-agent package needs to be changed to use the UDisks API and change its dependecies to udisks2 packages (this is already reported).

Comment 5 Vojtech Trefny 2018-04-19 07:11:36 UTC

*** This bug has been marked as a duplicate of bug 1527320 ***


Note You need to log in before you can comment on or make changes to this bug.