Bug 156930 - RHN Provisioning won't sync to a package profile during kickstart
RHN Provisioning won't sync to a package profile during kickstart
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
370
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Max Spevack
:
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2005-05-05 10:06 EDT by Dave Johnson
Modified: 2007-07-31 11:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-11 16:04:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2005-05-05 10:06:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Selecting a package profile for synchronization within the context of editing a kickstart profile does not actually cause synchronization to occur.  A system provisioned with this kickstart profile is installed with the package list listed in the "packages" section of the kickstart profile and the package profile does is not adhered to.  

Comparing a system provisioned with this kickstart profile against the package profile selected to be synchronized shows unexpected package differences.

Version-Release number of selected component (if applicable):
RHN Satellite 3.7 (rhns-3.7.1-8.rhel3)

How reproducible:
Always

Steps to Reproduce:
1. Install a system with @Base
2. Update it by installing "ami" (for example)
3. Create a package profile of the system and verify the profile contains "ami" (and dependencies)
4. Create a kickstart profile and select the above package profile for sync
5. Kickstart the system (I chose not to re-provision from the UI) 
  

Actual Results:  The system was provisioned with the latest packages from the distribution I selected, according to the packages selected by default within RHN Provisioning (@Base).  The additional packages from the profile were not installed ("ami").

Expected Results:  The system should have been installed exactly as specified in the package profile.

Additional info:

Syncing to a package profile works fine outside of kickstarting a system.  Syncing to the same profile using the same system above -after installation- works fine.
Comment 1 Shannon Hughes 2005-07-06 11:21:14 EDT
5. Kickstart the system (I chose not to re-provision from the UI) 

how are yo kickstarting the system in bullet 5? 
Comment 2 Shannon Hughes 2005-07-06 12:05:18 EDT
I think this is a backend issue. 

When creating a profile and synching to a package profile the server profile id
is correctly added to the rhnkickstartdefaults.server_profile_id column. Then
when visiting the kickstart url the server profile id is added to the
rhnkickstartsession.server_profile_id column correctly as well. 

jconnor is going to take a look as well. 
Comment 3 Shannon Hughes 2005-07-11 16:04:46 EDT
If you don't provision from the UI the syncing action will not get scheduled.
The sync action is a separate action from the actual kickstart. 

closing as not a bug. 
Comment 4 Dave Johnson 2006-05-22 17:05:02 EDT
I don't follow what you're trying to say here, "If you don't provision from the
UI the syncing action will not get scheduled."

What is the function of the drop down menu in the kickstart post options screen
(within RHN Satellite UI) that is labeled "Package Sync" and provides a list of
existing package profiles?  

This would seem to allow for the profile of the system being kickstarted to be
sync'd with the selected profile.  This does not appear to do anything.

Is this intended to work only when "re-provisioning" via the UI?

Note You need to log in before you can comment on or make changes to this bug.