Bug 156932 - libnetsnmp is missing dependency on libcrypto
libnetsnmp is missing dependency on libcrypto
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-05 10:25 EDT by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.2.1-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 02:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-05-05 10:25:07 EDT
[root@trash ~]# rpm -qf /usr/lib/libnetsnmp.so.5
net-snmp-libs-5.2.1-10
[root@trash ~]# ldd -r /usr/lib/libnetsnmp.so.5
undefined symbol: EVP_DigestInit        (/usr/lib/libnetsnmp.so.5)
undefined symbol: EVP_DigestFinal       (/usr/lib/libnetsnmp.so.5)

libnetsnmp should be linked against -lcrypto since it depends on it.  This makes
prelink happier if nothing else.
Comment 1 Radek Vokal 2005-05-12 02:52:34 EDT
Fixed, will come out with next rawhide version 

Note You need to log in before you can comment on or make changes to this bug.