Bug 1569373 - Error logs in ovs pod about library missing for PMD
Summary: Error logs in ovs pod about library missing for PMD
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.0
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 07:32 UTC by Meng Bo
Modified: 2019-11-15 16:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 16:57:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2018-04-19 07:32:49 UTC
Description of problem:
Setup OCP cluster with bootstrapping mode. Check the ovs pod log after the system is running.
Some library missing log found in the pod.

Version-Release number of selected component (if applicable):
oc v3.10.0-0.22.0
kubernetes v1.10.0+b81c8f8
openshift3/ose-node    v3.10   cfcafb325004
openvswitch-2.9.0-15.el7fdp.x86_64

How reproducible:
always

Steps to Reproduce:
1. Setup OCP cluster
2. Check the ovs pod log
3.

Actual results:
# oc logs ovs-8r7mf
Starting ovsdb-server [  OK  ]
PMD: net_mlx4: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx4: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx4)
PMD: net_mlx5: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx5: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx5)
Configuring Open vSwitch system IDs [  OK  ]
PMD: net_mlx4: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx4: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx4)
PMD: net_mlx5: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx5: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx5)
Starting ovs-vswitchd [  OK  ]
Enabling remote OVSDB managers [  OK  ]


Expected results:
Should not have such errors/warnings.

Additional info:

Comment 1 Ben Bennett 2018-04-24 13:23:54 UTC
Aaron, since we don't care about DPDK or the Mellanox PMD in this use case, the warning message seems harmless... but do you know any way that we can suppress it at run time?

Comment 2 Aaron Conole 2018-06-01 21:31:03 UTC
I don't know currently how it can be suppressed.  Perhaps the -37 version will pull in the correct rdma core dependencies so it won't be an issue.  Please retest when the newest version drops.

Comment 5 Ben Bennett 2019-11-15 16:57:33 UTC
This is really something that needs to be fixed upstream in OVN and is completely harmless anyway.  It's just log noise that confuses people.


Note You need to log in before you can comment on or make changes to this bug.