Bug 156945 - NETDEV WATCHDOG: eth0: transmit timed out
NETDEV WATCHDOG: eth0: transmit timed out
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-05 12:11 EDT by Naveed Ahmad
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 10:26:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveed Ahmad 2005-05-05 12:11:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
We have recently installed RHEL v4 ES on one of our computers and the Network Card is not working. 

This computer previously had RHEL v3 ES installed and all the components (including this network card) were working absolutely fine. We did a fresh install of RHEL v4 ES on this computer.

The problem is that after installing RHEL v4 ES the Network Card is not working.

The network card is configured properly. An extract from "/var/log/dmesg" is as below:

ACPI: PCI interrupt 0000:00:0d.0[A]: no GSI - using IRQ 10
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xc00, 00:e0:29:63:73:17, IRQ 10
eth0: Identified 8139 chip type 'RTL-8139B'

The output of "ifconfig" command indicates that the card is configured properly.

We have noticed that the following 2 error messages are appearing repeatedly in the /var/log/messages log file:

May 5 16:43:21 sky2 kernel: NETDEV WATCHDOG: eth0: transmit timed out
May 5 16:43:21 sky2 kernel: eth0: link up, 100Mbps, full duplex, lpa 0x45E1

Any suggestions please ...?


Version-Release number of selected component (if applicable):
kernel-2.6.9-5.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot the server.
2. Try accessing the LAN.
  

Actual Results:  The Network Card does not work.

Expected Results:  The Network Card should work.

Additional info:

I have noticed that a similar bug has been reported for Fedora (Bug Reference #139514).
Comment 1 John W. Linville 2005-05-11 09:40:48 EDT
Nothing immediately comes to mind...have you tried booting w/ "acpi=off" 
and/or "noapic" on the kernel command line?  What were the results?  Thanks! 
Comment 2 John W. Linville 2005-06-27 10:25:59 EDT
Closed due to lack of respone...please reopen if/when requested information 
becomes available... 

Note You need to log in before you can comment on or make changes to this bug.