Bug 156949 - Regression in util-linux-2.12a-24
Regression in util-linux-2.12a-24
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-05 12:39 EDT by Ronald Kuetemeier
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 09:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronald Kuetemeier 2005-05-05 12:39:54 EDT
Description of problem:
With util-linux-2.12a-24.1.i386.rpm
my system will not boot. The remount to rw fails. 
Backed out to util-linux-2.12a-23 and it works fine.
System uses sata raid and lvm with labels in fstab which seems to confuse mount.
Runlevel 1 requires a manual remount to rw even the drive shows up as mounted rw .  

Version-Release number of selected component (if applicable):
util-linux-2.12a-24
Comment 1 Karel Zak 2005-05-05 14:05:27 EDT
What does it mean "failed"? Any error message?

Are you sure that you don't have any duplicate label? (It means same label on
more devices).
Comment 2 Erhard Kroeger 2005-05-05 15:48:28 EDT
I have the same problem with util-linux-2.12a-24.1. The filesystem remains
read-only during booting by grub. Thus touch, write, delete operations, and
writing failures to logs fail (only failure messages on the monitor). After some
time the system hangs before boot can finish. Regression to util-linux-2.12a-23
lets the system boot succesfully again.   
Comment 3 Ronald Kuetemeier 2005-05-05 15:52:07 EDT
What does it mean "failed"? Any error message?

Just that, doesn't boot since the drive is read only. Lots of error msg that
files on the drive can not be modifyed.

Are you sure that you don't have any duplicate label? (It means same label on
more devices).

Yeap, checked and rechecked and used 2.12a-23 without _any_ changes in setup and
it works. I have a "save" partition outside lvm and it's not mounting that
correctley either. But on shudown 2.12a-24 complains about duplicate labels,
where that comes from I don't know, I cant' find any.
FSTAB:
LABEL=/                 /usr2                   ext2    defaults        1 2
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=LogVol00          /                       ext3    defaults        1 1
LABEL=SWAP-sda4         swap                    swap    defaults        0 0

e2label:
[root@dell ~]# e2label /dev/dm-0
LogVol00
[root@dell ~]# e2label /dev/sda1
/boot
[root@dell ~]# e2label /dev/sda2
/




 
Comment 4 Erhard Kroeger 2005-05-05 16:09:13 EDT
I find in /etc/fstab

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/hda5               swap                    swap    defaults        0 0
/dev/hdd                /media/cdrecorder       auto   
pamconsole,exec,noauto,managed 0 0
/dev/hdc                /media/cdrom            auto   
pamconsole,exec,noauto,managed 0 0
/dev/fd0                /media/floppy           auto   
pamconsole,exec,noauto,managed 0 0

and from fdisk of my 2 harddrives I get

[root@fritz ~]# fdisk -l /dev/hda

Platte /dev/hda: 163.9 GByte, 163928604672 Byte
255 Köpfe, 63 Sektoren/Spuren, 19929 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

   Gerät Boot      Start         End      Blocks   Id  System
/dev/hda1               1        1531    12297726    c  W95 FAT32 (LBA)
/dev/hda2   *        1532        2806    10241437+  83  Linux
/dev/hda3            2807        3504     5606685    7  HPFS/NTFS
/dev/hda4            3505       19929   131933812+   f  W95 Ext'd (LBA)
/dev/hda5            3505        3575      570276   82  Linux Swap
/dev/hda6            3576       19929   131363473+   7  HPFS/NTFS
[root@fritz ~]# fdisk -l /dev/hdb

Platte /dev/hdb: 81.9 GByte, 81964302336 Byte
255 Köpfe, 63 Sektoren/Spuren, 9964 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

   Gerät Boot      Start         End      Blocks   Id  System
/dev/hdb1            1495        8114    53175150    f  W95 Ext'd (LBA)
/dev/hdb2               1        1494    12000523+  83  Linux
/dev/hdb5            1495        3013    12201336    b  W95 FAT32
/dev/hdb6            3014        4289    10249438+  83  Linux
/dev/hdb7            4290        8114    30724281    7  HPFS/NTFS

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge
[root@fritz ~]#
Comment 5 Karel Zak 2005-05-05 17:12:18 EDT
There's only one difference between releases -23 and -24. The old version
doesn't check duplicate labels correctly (see bug #154202. It means with
releases <=23 your system works although there's duplicate labels. The others
words: it doesn't mean that your system configuration is correct if it works
with util-linux-2.12a-23.

It's not important that devices you have in /etc/fstab. The mount command scan
and check all system devices (from /proc/partitions, /proc/lvm/VGs or
/dev/mapper). You can try (in fstab) mount by direct paths to devices rather
than by LABELs.

I think you have two some labels in system or you have exported same partition
as two different devices (by LVM, DM, ..).

I'm going to write small util that will check system devices for duplicate labels.
Comment 6 Ronald Kuetemeier 2005-05-05 17:43:55 EDT
Sorry no cigar, still no dups. See script.

[root@dell ~]# cat /proc/partitions
major minor  #blocks  name

   8     0   78091136 sda
   8     1     104391 sda1
   8     2   19543072 sda2
   8     3   56452410 sda3
   8     4    1984027 sda4
 253     0   56451072 dm-0

[root@dell ~]# for DISK in `awk '{print $4}' /proc/partitions`;do tune2fs -l
"/dev/"$DISK | grep -i volume;done
tune2fs: No such file or directory while trying to open /dev/name
Couldn't find valid filesystem superblock.
tune2fs: Bad magic number in super-block while trying to open /dev/sda
Couldn't find valid filesystem superblock.
Filesystem volume name:   /boot
Filesystem volume name:   /
Filesystem volume name:   <none>
tune2fs: Bad magic number in super-block while trying to open /dev/sda4
Couldn't find valid filesystem superblock.
Filesystem volume name:   LogVol00


Comment 7 Karel Zak 2005-05-05 18:13:54 EDT
Ah... I think I found a problem. There is other bug (bug #76467) that isn't
fixed in FC-3. This bug was hidden, because old releases ignore the last device
from /proc/partitions during duplicate labels checking. The problem is that the
mount loads information about your "dm-0" two times... 

Thanks!
Comment 8 Ronald Kuetemeier 2005-05-05 18:17:40 EDT
Ahhhh here we go.  Just looked at:

[root@dell ~]# mount
/dev/dm-0 on / type ext3 (rw)
....

[root@dell ~]# tune2fs -l /dev/dm-0 | grep volume
Filesystem volume name:   LogVol00

[root@dell ~]# tune2fs -l /dev/mapper/VolGroup00-LogVol00 | grep volume
Filesystem volume name:   LogVol00

Problem is I don't know where /dev/dm-0 comes from. I didn't create it. Thought
that's a thingy from udev and a short for the /dev/mapper/VolGroup00-LogVol00
which I created.

So who/what ever created /dev/dm-0 has created the problem and the dup since
they are the same, i.e /dev/dm-0 and /dev/mapper/VolGroup00-LogVol00.
Comment 9 Karel Zak 2005-05-05 18:37:26 EDT
The mount should be ignore dm-0 in /proc/partitions, because there's other code
that reads /dev/mapper/.

util-linux-2.12a-24.2 with bugfix is already on the way.

Note You need to log in before you can comment on or make changes to this bug.