Bug 1569635 - openshift-ansible aws provisioning - unable to use "openshift_master_cluster_hostname"
Summary: openshift-ansible aws provisioning - unable to use "openshift_master_cluster_...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.0
Assignee: Chris Callegari
QA Contact: sheng.lao
URL:
Whiteboard:
Depends On: 1619380
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 15:59 UTC by Matt Woodson
Modified: 2018-12-21 15:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
AWS provisioning no longer overrides the openshift_master_cluster_hostname setting.
Clone Of:
Environment:
Last Closed: 2018-12-21 15:16:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Woodson 2018-04-19 15:59:59 UTC
Description of problem:

Using aws provisioning, the master_facts:

https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_aws/tasks/master_facts.yml#L15

Will override the openshift_master_cluster_hostname variable from the inventory.  I've tried setting it in the inventory, and this variable is always overridden with the dns name of the ELB.

This also ends up putting the elb name into the master-config.yaml, even if it's set in the inventory.

I am used to this being a DNS name.  This bugzilla with a hook to DNS will help this be overcome:

https://bugzilla.redhat.com/show_bug.cgi?id=1569631

Version-Release number of selected component (if applicable):

openshift-ansible 3.9, 3.10

Comment 1 Steve Speicher 2018-05-17 20:15:37 UTC
Setting sev to high since OpsBlocker

Comment 2 Chris Callegari 2018-07-17 01:56:02 UTC
https://trello.com/c/R6yaXLpF/666-aws-dns-hook

Comment 4 sheng.lao 2018-08-10 12:32:58 UTC
Hi, Matt Woodson:
 Would you please to help me: What's the procedure to reproduce this problem.

Comment 7 Chris Callegari 2018-08-20 19:29:34 UTC
Sorry this has become a hassle

Fix is here... https://github.com/openshift/openshift-ansible/pull/9680

We're waiting on merge

Comment 8 Chris Callegari 2018-08-22 18:22:06 UTC
pull/9680 has /lgtm tag.  It should get merged over night.

Please test from master tomorrow.

Comment 9 sheng.lao 2018-08-23 06:53:14 UTC
Waiting https://bugzilla.redhat.com/show_bug.cgi?id=1620536

Comment 13 Chris Callegari 2018-08-31 19:56:43 UTC
pull/9846 has been tagged lgtm.  Please recut the ami and rerun provision_install.

Comment 14 sheng.lao 2018-09-12 08:19:55 UTC
Failed at the task: Wait for control plane pods to appear

Error messages: 
Unable to connect to the server: dial tcp: lookup api.goodday.com on 172.31.0.2:53: no such host

So, It seems that the DNS don't works well.

# oc get pod 
Unable to connect to the server: dial tcp: lookup api.goodday.com on 172.31.0.2:53: no such host

# docker ps
CONTAINER ID        IMAGE                                                            COMMAND                  CREATED             STATUS              PORTS               NAMES
aee295219163        7f9f698aa5c8                                                     "/bin/bash -c '#!/..."   6 minutes ago       Up 6 minutes                            k8s_api_master-api-ip-172-31-57-113.ec2.internal_kube-system_2b428cda0890c4a59cc5bacdd8e39049_0

# docker top aee295219163
UID                 PID                 PPID                C                   STIME               TTY                 TIME                CMD
root                18637               18611               7                   03:59               ?                   00:00:59            openshift start master api --config=/etc/origin/master/master-config.yaml --loglevel=2

# netstat -anp |grep 18637 |grep 443
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      18637/openshift     
tcp        0      0 172.31.57.113:443       172.31.57.113:49722     ESTABLISHED 18637/openshift     
tcp        0      0 127.0.0.1:40994         127.0.0.1:443           ESTABLISHED 18637/openshift

Comment 16 sheng.lao 2018-09-12 15:13:45 UTC
Fixed at: openshift-ansible-3.11.0-0.35.0-25-g7a49331

According to bz-1569631, I add a record of type, "A IPv4 Address", with the same value of openshift_master_cluster_hostname. and create the "DHCP Options Sets", associated the VPC ,working with Private Hosted Zones.

Comment 18 Luke Meyer 2018-12-21 15:16:34 UTC
Closing bugs that were verified and targeted for GA but for some reason were not picked up by errata. This bug fix should be present in current 3.11 release content.


Note You need to log in before you can comment on or make changes to this bug.