Bug 1569691 - RHEL7 systemd on default XFS filesystem generates "Failed to set file attributes" in dmesg log
Summary: RHEL7 systemd on default XFS filesystem generates "Failed to set file attribu...
Keywords:
Status: CLOSED DUPLICATE of bug 1299714
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 19:52 UTC by Matthew Whitehead
Modified: 2018-04-19 20:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 20:16:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matthew Whitehead 2018-04-19 19:52:31 UTC
Description of problem: On a default RHEL7.4 install, we get the following message in dmesg (and it does NOT appear in journalctl logs):

"Failed to set file attributes: Operation not supported".

I believe this comes from the systemd function setup_keys() in this code fragment:


	/* Enable secure remove, exclusion from dump, synchronous                                                                   
         * writing and in-place updating */
        r = chattr_fd(fd, true, FS_SECRM_FL|FS_NODUMP_FL|FS_SYNC_FL|FS_NOCOW_FL);
	if (r < 0)
                log_warning_errno(errno, "Failed to set file attributes: %m");


The upstream XFS kernel code looks like it fails in xfs_ioc_setxflags():

        if (flags & ~(FS_IMMUTABLE_FL | FS_APPEND_FL | \
                      FS_NOATIME_FL | FS_NODUMP_FL | \
                      FS_SYNC_FL))
                return -EOPNOTSUPP;


Version-Release number of selected component (if applicable): RHEL7.4


How reproducible: 100% on default RHEL7 XFS filesystem. Note: it _only_ appears in dmesg output (not journalctl logs)


Steps to Reproduce:
1. Do default install
2. Look at 'dmesg' output
3.

Actual results: Warning message.


Expected results: No warning message expected for a default install.


Additional info:

Comment 2 Frank Hirtz 2018-04-19 20:16:44 UTC

*** This bug has been marked as a duplicate of bug 1299714 ***


Note You need to log in before you can comment on or make changes to this bug.