Bug 1569752 - Installer remind haven't /boot/efi, but it exists.
Summary: Installer remind haven't /boot/efi, but it exists.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 23:57 UTC by robberphex
Modified: 2018-05-04 09:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 08:17:15 UTC
Type: Bug


Attachments (Terms of Use)
The partition list (309.96 KB, image/png)
2018-04-19 23:58 UTC, robberphex
no flags Details
error message (260.42 KB, image/png)
2018-04-19 23:58 UTC, robberphex
no flags Details
efi partition (73.77 KB, image/png)
2018-04-20 15:25 UTC, robberphex
no flags Details
efi partition in anaconda (298.44 KB, image/png)
2018-04-20 15:27 UTC, robberphex
no flags Details
anaconda.log (40.41 KB, text/plain)
2018-04-20 15:29 UTC, robberphex
no flags Details
dbus.log (2.77 KB, text/plain)
2018-04-20 15:30 UTC, robberphex
no flags Details
ifcfg.log (1.78 KB, text/plain)
2018-04-20 15:33 UTC, robberphex
no flags Details
program.log (48.57 KB, text/plain)
2018-04-20 15:34 UTC, robberphex
no flags Details
storage.log (188.96 KB, text/plain)
2018-04-20 15:35 UTC, robberphex
no flags Details
storage.state (24.00 KB, application/octet-stream)
2018-04-20 15:36 UTC, robberphex
no flags Details

Description robberphex 2018-04-19 23:57:01 UTC
Description of problem:

The installer remind to create mount point of /boot/efi, even if I have created it.

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-28_Beta-1.3.iso 
MBP mid 2015

How reproducible:


Steps to Reproduce:
1. Boot with flash disk
2. start installer
3. configure partition, for /boot/efi, /boot, / and swap.
4. press "Done"
5. remind that haven't /boot/efi

Actual results:
remind that haven't /boot/efi

Expected results:
Contiue to next step.

Additional info:

Comment 1 robberphex 2018-04-19 23:58:10 UTC
Created attachment 1424329 [details]
The partition list

Comment 2 robberphex 2018-04-19 23:58:53 UTC
Created attachment 1424330 [details]
error message

Comment 3 Zamir SUN 2018-04-20 06:29:35 UTC
Hi,

Can you show what's the filesystem type you are using for the /boot/efi mountpoint? That would be helpful for debug this.

Comment 4 robberphex 2018-04-20 06:36:21 UTC
(In reply to Zamir SUN from comment #3)
> Hi,
> 
> Can you show what's the filesystem type you are using for the /boot/efi
> mountpoint? That would be helpful for debug this.

the disk partition table is GPT.
the /boot/efi filesystem type is EFI system.

Comment 5 Vendula Poncova 2018-04-20 09:33:41 UTC
Please, attach all files from /tmp/*log with Anaconda logs.

Comment 6 Zamir SUN 2018-04-20 09:47:03 UTC
Since you are using MBP, I find something interesting...

https://github.com/rhinstaller/anaconda/blob/master/pyanaconda/platform.py#L174

Along with comment 5, can you also check if you have macefi as a filesystem type? And if it exists, can you try if using that filesystem type can fix your issue or not?

Comment 7 robberphex 2018-04-20 15:25:01 UTC
Created attachment 1424571 [details]
efi partition

Comment 8 robberphex 2018-04-20 15:27:35 UTC
Created attachment 1424572 [details]
efi partition in anaconda

Comment 9 robberphex 2018-04-20 15:29:10 UTC
Created attachment 1424573 [details]
anaconda.log

Comment 10 robberphex 2018-04-20 15:30:20 UTC
blivet-gui-utils.log is empty/zero size.

Comment 11 robberphex 2018-04-20 15:30:53 UTC
Created attachment 1424574 [details]
dbus.log

Comment 12 robberphex 2018-04-20 15:33:31 UTC
Created attachment 1424587 [details]
ifcfg.log

Comment 13 robberphex 2018-04-20 15:34:04 UTC
packaging.log is empty/zero size

Comment 14 robberphex 2018-04-20 15:34:59 UTC
Created attachment 1424589 [details]
program.log

Comment 15 robberphex 2018-04-20 15:35:59 UTC
Created attachment 1424590 [details]
storage.log

Comment 16 robberphex 2018-04-20 15:36:13 UTC
Created attachment 1424591 [details]
storage.state

Comment 17 Zamir SUN 2018-04-23 09:12:48 UTC
(In reply to robberphex from comment #7)
> Created attachment 1424571 [details]
> efi partition

It seems you are trying to create another EFI partition in parallel. From booting perspective only one EFI is needed. So can you try config the installer to use your first EFI partition (the 210M one), just mount it under /boot/efi *without* reformat. And then proceed the installation?

Comment 18 robberphex 2018-04-25 02:12:13 UTC
(In reply to Zamir SUN from comment #17)
> (In reply to robberphex from comment #7)
> > Created attachment 1424571 [details]
> > efi partition
> 
> It seems you are trying to create another EFI partition in parallel. From
> booting perspective only one EFI is needed. So can you try config the
> installer to use your first EFI partition (the 210M one), just mount it
> under /boot/efi *without* reformat. And then proceed the installation?

I tried two efi partition, but it doesn't work, same error.
(not-format and re-format also tried)

Comment 19 Vendula Poncova 2018-04-27 11:27:36 UTC
Can you try to use the filesystem type "Linux HFS+ ESP" for your /boot/efi mountpoint?

Comment 20 robberphex 2018-05-04 08:17:15 UTC
"Linux HFS+ ESP" works for me!

Thanks!

The error message "you must include an EFI System Partition..." misled me.

Comment 21 Vendula Poncova 2018-05-04 09:54:32 UTC
Fixed the error message: https://github.com/rhinstaller/anaconda/pull/1469


Note You need to log in before you can comment on or make changes to this bug.