Bug 1570085 - High request traffic from OpenShift to Cinder when using controller managed attach/detach
Summary: High request traffic from OpenShift to Cinder when using controller managed a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Hemant Kumar
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 15:28 UTC by Robert Bost
Modified: 2018-05-18 14:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-18 14:31:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3420081 0 None None None 2018-04-20 15:31:23 UTC

Description Robert Bost 2018-04-20 15:28:07 UTC
Description of problem:


Version-Release number of selected component (if applicable): 3.6.173.0.96


Steps to Reproduce:
Enable controller managed attach/detach:

kubeletArguments:
  enable-controller-attach-detach:
  - "true"

Seems to reproduce issue for a customer.

Actual results: Customer seeing nearly 26k requests per hour delivered to OpenStack Cinder.


Expected results: Lower request volume.


Additional info:
Customer reports "When I tcpdump the data I see that once every 10 sec. there's a bunch of traffic going to their [cinder] api from each node in the cluster". 


Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 18 Hemant Kumar 2018-05-18 14:31:45 UTC
Please open another bug with networking team because as I understand the provided workaround worked for fixing API calls to Cinder.


Note You need to log in before you can comment on or make changes to this bug.