Bug 157009 - Disabled device on shared IRQ
Disabled device on shared IRQ
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-05 18:05 EDT by Brian DeFeyter
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 10:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian DeFeyter 2005-05-05 18:05:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
This happens on an older pIII Dell PowerEdge 2550. In the BIOS there are only a couple of IRQs available to define for integrated devices. Some have to be shared. 

My system can boot, and then at some random point after I will get this message:

Message from syslogd@vhost-master at Thu May  5 17:52:23 2005 ...
vhost-master kernel: Disabling IRQ #11 

May 5 17:52:23 vhost-master kernel: irq 11: nobody cared! (screaming interrupt?) 
May 5 17:52:23 vhost-master kernel: irq 11: Please try booting with acpi=off and report a bug 
May 5 17:52:23 vhost-master kernel: [<c0107c2f>] __report_bad_irq+0x3a/0x77 
May 5 17:52:23 vhost-master kernel: [<c01080ed>] note_interrupt+0x191/0x1b7 
May 5 17:52:23 vhost-master kernel: [<c0108583>] do_IRQ+0x19a/0x242 
May 5 17:52:23 vhost-master kernel: [<c0301e88>] common_interrupt+0x18/0x20 
May 5 17:52:23 vhost-master kernel: [<c0124d7c>] __do_softirq+0x2c/0x79 
May 5 17:52:23 vhost-master kernel: [<c010905b>] do_softirq+0x46/0x4d 
May 5 17:52:23 vhost-master kernel: ======================= 
May 5 17:52:23 vhost-master kernel: [<c0108622>] do_IRQ+0x239/0x242 
May 5 17:52:23 vhost-master kernel: [<c0301e88>] common_interrupt+0x18/0x20 
May 5 17:52:23 vhost-master kernel: [<c010403b>] default_idle+0x23/0x26 
May 5 17:52:23 vhost-master kernel: [<c010408c>] cpu_idle+0x1f/0x34 
May 5 17:52:23 vhost-master kernel: [<c03a76b4>] start_kernel+0x20f/0x211 
May 5 17:52:23 vhost-master kernel: handlers: 
May 5 17:52:23 vhost-master kernel: [<f8959421>] (tg3_interrupt+0x0/0x19f [tg3]) 
May 5 17:52:23 vhost-master kernel: Disabling IRQ #11

My SCSI controller and primary ethernet device were originally both using IRQ #11. I disabled my second ethernet device and re-arranged the IRQs to hopefully do away with the sharing, but I can still reproduce with any decent amount of network activity.

Version-Release number of selected component (if applicable):
2.6.9-5.0.5.EL

How reproducible:
Always

Steps to Reproduce:
1. Mount an NFS share
2. Start performing operations on the NFS share
3. Doesn't take long, and the IRQ will be disabled

This isn't the only method. It will happen when the system is idle as well (arp traffic)
  

Actual Results:  Message from syslogd@vhost-master at Thu May  5 17:52:23 2005 ...
vhost-master kernel: Disabling IRQ #11 

May 5 17:52:23 vhost-master kernel: irq 11: nobody cared! (screaming interrupt?) 
May 5 17:52:23 vhost-master kernel: irq 11: Please try booting with acpi=off and report a bug 
May 5 17:52:23 vhost-master kernel: [<c0107c2f>] __report_bad_irq+0x3a/0x77 
May 5 17:52:23 vhost-master kernel: [<c01080ed>] note_interrupt+0x191/0x1b7 
May 5 17:52:23 vhost-master kernel: [<c0108583>] do_IRQ+0x19a/0x242 
May 5 17:52:23 vhost-master kernel: [<c0301e88>] common_interrupt+0x18/0x20 
May 5 17:52:23 vhost-master kernel: [<c0124d7c>] __do_softirq+0x2c/0x79 
May 5 17:52:23 vhost-master kernel: [<c010905b>] do_softirq+0x46/0x4d 
May 5 17:52:23 vhost-master kernel: ======================= 
May 5 17:52:23 vhost-master kernel: [<c0108622>] do_IRQ+0x239/0x242 
May 5 17:52:23 vhost-master kernel: [<c0301e88>] common_interrupt+0x18/0x20 
May 5 17:52:23 vhost-master kernel: [<c010403b>] default_idle+0x23/0x26 
May 5 17:52:23 vhost-master kernel: [<c010408c>] cpu_idle+0x1f/0x34 
May 5 17:52:23 vhost-master kernel: [<c03a76b4>] start_kernel+0x20f/0x211 
May 5 17:52:23 vhost-master kernel: handlers: 
May 5 17:52:23 vhost-master kernel: [<f8959421>] (tg3_interrupt+0x0/0x19f [tg3]) 
May 5 17:52:23 vhost-master kernel: Disabling IRQ #11

Ethernet device is disabled

Additional info:
Comment 1 John W. Linville 2005-05-11 09:34:46 EDT
Did you try booting w/ "acpi=off" and/or "noapic" on the kernel command line?  
What were the results?  Thanks! 
Comment 2 Brian DeFeyter 2005-05-11 10:09:35 EDT
Yes, I did try with "acpi=off" and had the same results. I have since switched
to using a different onboard ethernet device and no longer have the problem. I'm
wondering if this could have been a hardware issue?
Comment 3 John W. Linville 2005-05-12 10:12:27 EDT
Hmmm...well, it at least sounds plausible that you have/had some bum hardware. 
 
I'm going to close this as NOTABUG.  Please reopen it if you continue to have 
problems, especially with other boards.  Thanks! 

Note You need to log in before you can comment on or make changes to this bug.