Bug 1570165 - failure to refresh dynamic dialogs (dropdowns) after upgrade CF 4.5 -> 4.6
Summary: failure to refresh dynamic dialogs (dropdowns) after upgrade CF 4.5 -> 4.6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.2
Assignee: Tina Fitzgerald
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 19:08 UTC by Tuan
Modified: 2018-04-30 13:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 13:49:53 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Script Errors (38.23 KB, image/png)
2018-04-23 21:04 UTC, William Fitzgerald
no flags Details

Comment 4 William Fitzgerald 2018-04-23 21:04:05 UTC
Created attachment 1425744 [details]
Script Errors

Comment 5 William Fitzgerald 2018-04-23 21:05:09 UTC
Created 5.9.1.2 appliance 10.8.197.224.

Downloaded and imported datastore_2018_04_17_POST_CF46upg.zip 

Downloaded and imported dialog_export_20180417_132606_lx_v41.yml (43.5 kB) 

Created Catalog Service using dialog.


Seeing this multiple ties in automation.log
ERROR -- : Error decrypting password can not decrypt v2_key encrypted string. Possible cause: Password value was encrypted with a different encryption key

Dialog is showing Script Errors when I order the Service.    

Added screenshot: Script Errors


Billy

Comment 7 William Fitzgerald 2018-04-24 18:41:01 UTC
I was able to get around the decrypting password Errors.  The dialog is still not working.  I am now getting an error when I try to edit the dialog and haven't been able to edit it since.

Billy

Comment 8 Tina Fitzgerald 2018-04-24 19:52:06 UTC
Hi Tuan,

I believe this issue is caused by:
https://bugzilla.redhat.com/show_bug.cgi?id=1568440.

Here's the error from Problem Description above: 
[----] E, [2018-04-17T13:03:31.206272 #2282:175cb04] ERROR -- : [NoMethodError]: undefined method `root' for true:TrueClass  Method:[block in method_missing]
[----] E, [2018-04-17T13:03:31.216071 #2282:175cb04] ERROR -- : /var/www/miq/vmdb/app/models/dynamic_dialog_field_value_processor.rb:14:in `values_from_automate'

Here is the associated automation.log entry showing the error: 
--] E, [2018-04-17T13:03:31.133284 #2282:9c88d64] ERROR -- : <AEMethod dlg_cf_get_net_selector> Invalid value for MCVlanRole -> [["NONE", "NINGUNA"]]


Here's the custom Automate code that generates that log message:
/Integration/PHPIPAM/phpipam_ops/dlg_cf_get_net_selector

if expected_MCVlanRole.to_s.upcase == "MPLS" or expected_MCVlanRole == "BACKEND"
    $evm.log(:info, "Looking for MCVlanRole -> #{expected_MCVlanRole}") if m_debug
    
else
    $evm.log(:error, "Invalid value for MCVlanRole -> #{expected_MCVlanRole}")
    exit MIQ_ABORT
end  

In this case, the error would still be present because the value is not "MLPS" or "BACKEND". 

Can we re-evaluate this once the customer has the fix for:
https://bugzilla.redhat.com/show_bug.cgi?id=1568440.

Thanks,
Tina

Comment 10 Tina Fitzgerald 2018-04-27 15:04:14 UTC
Hi Tuan,

It's important to point out that although we have a fix for the multiple values reported in this ticket: 
https://bugzilla.redhat.com/show_bug.cgi?id=1568440.

The custom script looks like it would still fail based on the detail in comment 8.

Thanks,
Tina

Comment 11 Tuan 2018-04-27 18:58:42 UTC
Hello Tina,
     Talked to Josh and it seems like since The customer has reverted back due to the number of dialog issues, we can ask them to clone their db and reproduce this if necessary.


Thanks
Tuan

Comment 12 Tina Fitzgerald 2018-04-30 13:49:53 UTC
Closing per discussion with Josh.


Note You need to log in before you can comment on or make changes to this bug.