Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1570365 - Standalone telemetry node: no measures available
Summary: Standalone telemetry node: no measures available
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z2
: 13.0 (Queens)
Assignee: Mehdi ABAAKOUK
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks: 1458303
TreeView+ depends on / blocked
 
Reported: 2018-04-22 11:07 UTC by Sasha Smolyak
Modified: 2018-09-03 10:36 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 10:36:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1766507 0 None None None 2018-04-24 08:14:16 UTC
OpenStack gerrit 563504 0 None MERGED Telemetry services need to access to Storage 2020-08-20 09:08:28 UTC
OpenStack gerrit 563715 0 None MERGED Telemetry services need to access to Storage 2020-08-20 09:08:29 UTC

Description Sasha Smolyak 2018-04-22 11:07:15 UTC
Description of problem:
When deploying composable roles with telemetry node (1 controller, 1 compute, 1 telemetry), building an instance and trying to observe measures of this instance, get an error:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at 
 [no address given] to inform them of the time this error occurred,
 and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
</body></html>
 (HTTP 500)

Version-Release number of selected component (if applicable):
gnocchi-api-4.2.3-1.el7ost.noarch
python-gnocchi-4.2.3-1.el7ost.noarch
gnocchi-metricd-4.2.3-1.el7ost.noarch
python2-collectd-gnocchi-1.7.0-1.el7ost.noarch
python2-gnocchiclient-7.0.1-1.el7ost.noarch
puppet-gnocchi-12.4.0-0.20180329032858.5dfa350.el7ost.noarch
gnocchi-statsd-4.2.3-1.el7ost.noarch
gnocchi-common-4.2.3-1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy composable roles with telemetry node, using infrared
2.Build an instance
3. Try to observe cpu measures of the instance

Actual results:
Get an error

Expected results:
Get cpu measures

Additional info:
/var/log/containers/gnocchi/gnocchi-metricd.log

2018-04-22 11:05:46,519 [25] ERROR    gnocchi.storage: Error processing new measures
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 505, in process_new_measures
    self._compute_and_store_timeseries(metric, measures)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 532, in _compute_and_store_timeseries
    metric, block_size=block_size, back_window=back_window)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 154, in _get_unaggregated_timeserie_and_unserialize
    metric)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/swift.py", line 193, in _get_unaggregated_timeserie
    self._build_unaggregated_timeserie_path(version))
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1799, in get_object
    headers=headers)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1691, in _retry
    service_token=self.service_token, **kwargs)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1167, in get_object
    conn.request(method, path, '', headers)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 439, in request
    files=files, **self.requests_args)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 422, in _request
    return self.request_session.request(*arg, **kwarg)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 518, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 639, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 502, in send
    raise ConnectionError(e, request=request)
ConnectionError: HTTPConnectionPool(host='172.17.3.11', port=8080): Max retries exceeded with url: /v1/AUTH_2e5439d447fb4f008396fd56d7d5bd7a/gnocchi.2845f016-a151-46b2-a552-51b37ad6a60c/none_v3 (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f2c9e550e50>: Failed to establish a new connection: [Errno 113] No route to host',))

Comment 14 Sasha Smolyak 2018-09-02 10:30:44 UTC
All the measures are available


Note You need to log in before you can comment on or make changes to this bug.