Bug 1570931 - With latest minor update, decimal numbers are rewritten to exponent notation in hieradata if they end with "0".
Summary: With latest minor update, decimal numbers are rewritten to exponent notation ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 10.0 (Newton)
Assignee: David Peacock
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 18:37 UTC by David Hill
Modified: 2019-04-15 13:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-15 13:55:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Hill 2018-04-23 18:37:17 UTC
Description of problem:
With latest minor update, decimal numbers in heat templates are rewritten to exponent notation in hieradata if they end with "0".  

Puppet output:
\u001b[mNotice: /Stage[main]/Cinder::Backup::Nfs/Cinder_config[DEFAULT/backup_file_size]/value: value changed '100000000' to '1e+08'\u001b[0m
\u001b[mNotice: /Stage[main]/Cinder::Backup::Nfs/Cinder_config[DEFAULT/backup_sha_block_size_bytes]/value: value changed '2000000' to '2e+06'\u001b[0m

templates file has this :
environments/6a-environment.yaml:    cinder::backup::nfs::backup_file_size: 100000000
environments/6a-environment.yaml:    cinder::backup::nfs::backup_sha_block_size_bytes: 100000000

hieradata has this:
cinder::backup::nfs::backup_file_size: 1e+08
cinder::backup::nfs::backup_sha_block_size_bytes: 2e+06

Adding 1 to the values like this:
environments/6a-environment.yaml:    cinder::backup::nfs::backup_file_size: 100000001
environments/6a-environment.yaml:    cinder::backup::nfs::backup_sha_block_size_bytes: 2000001

hieradata now has this:
controller_extraconfig.yaml:cinder::backup::nfs::backup_file_size: 100000001
controller_extraconfig.yaml:cinder::backup::nfs::backup_sha_block_size_bytes: 2000001

openstack-cinder-backup will probably start by now.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alex Schultz 2018-04-23 18:40:55 UTC
Since it's the hieradata getting written out in a different format, I think it's related to how heat is handling the yaml.

Comment 2 David Hill 2018-04-23 20:01:09 UTC
The following settings solvs the problem too:

environments/6a-environment.yaml:    cinder::backup::nfs::backup_file_size: "100000000"
environments/6a-environment.yaml:    cinder::backup::nfs::backup_sha_block_size_bytes: "2000000"

Comment 3 Thomas Hervé 2018-04-25 11:55:12 UTC
Can we get some more details from the environment? What was the starting version, and the target version? Was it a 7.4 to 7.5 upgrade?


Note You need to log in before you can comment on or make changes to this bug.