Bug 1571172 - [NMCI] dhcp-timeout_default_in_cfg test failure
Summary: [NMCI] dhcp-timeout_default_in_cfg test failure
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 08:50 UTC by Vladimir Benes
Modified: 2018-05-04 08:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 08:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 Beniamino Galvani 2018-04-24 18:44:04 UTC
Since devices used by tests are veths, the correct configuration should be:

 match-device=type:veth

instead of

 match-device=type:ethernet

With the latter, the longer dhcp-timeout is ignored and thus the test fails. On master there is a regression that makes veth devices match the type:ethernet directive, that's why I suppose the test succeeds there.

Comment 3 Thomas Haller 2018-04-24 19:32:26 UTC
(In reply to Beniamino Galvani from comment #2)
> On master there is a regression that makes veth devices match the
> type:ethernet directive, that's why I suppose the test succeeds there.

this one got fixed by https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=9731b06b787afc95e0e493b3c67ef13020af0538

Thank you Beniamino!!

Comment 4 Beniamino Galvani 2018-05-02 08:34:56 UTC
This should be fixed by this NM-CI change:

https://github.com/NetworkManager/NetworkManager-ci/pull/181

Comment 5 Beniamino Galvani 2018-05-04 08:46:21 UTC
The NM-CI pull request has been merged.


Note You need to log in before you can comment on or make changes to this bug.