Bug 1571188 - Error in Engine log for high writeRate from VMs
Summary: Error in Engine log for high writeRate from VMs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ovirt-4.4.1
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 09:20 UTC by Nirav Dave
Modified: 2020-08-03 15:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 14:01:31 UTC
oVirt Team: Virt
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)

Description Nirav Dave 2018-04-24 09:20:00 UTC
Description of problem:

Engine logs are throwing parse error when it receives huge writeRate from VDSM.

[org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler10) [373252d] Failed to parse 'writeRate' value '2433810432' to integer: For input string: "2433810432"

It seems the error is fired from VdsBrokerObjectsBuilder in diskData.setWriteRate(assignIntValue(disk, VdsProperties.vm_disk_write_rate));

It needs to change the assignIntValue to assignLongValue

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.6.2-0.1.el7.noarch

How reproducible:
Induce huge write I/O from VM. 

Actual results:

--------------------------------
2018-04-16 00:37:01,963+07 INFO  [org.ovirt.engine.?core.bll.aaa.TerminateSessionsForTokenCommand] (default task-62) [23003396] Running command: TerminateSessionsForTokenCommand internal: true.
2018-04-16 00:37:01,986+07 INFO  [org.ovirt.engine.core.sso.servlets.OAuthRevokeServlet] (default task-47) [] User admin@internal successfully logged out
2018-04-16 00:37:01,990+07 INFO  [org.ovirt.engine.core.bll.aaa.TerminateSessionsForTokenCommand] (default task-33) [4140f4c7] Running command: TerminateSessionsForTokenCommand internal: true.
2018-04-16 00:38:48,211+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler10) [373252d] Failed to parse 'writeRate' value '2433810432' to integer: For input string: "2433810432"
2018-04-16 00:41:48,683+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler10) [4b3bdda8] Failed to parse 'writeRate' value '2432188699' to integer: For input string: "2432188699"
2018-04-16 00:42:48,858+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler8) [2f34f7db] Failed to parse 'writeRate' value '4151793800' to integer: For input string: "4151793800"
2018-04-16 00:44:04,076+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler3) [437b070a] Failed to parse 'writeRate' value '2433810158' to integer: For input string: "2433810158"
2018-04-16 00:46:19,424+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler5) [5fdfeabc] Failed to parse 'writeRate' value '2575258623' to integer: For input string: "2575258623"
2018-04-16 00:47:34,702+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler7) [61beedb8] Failed to parse 'writeRate' value '2241157802' to integer: For input string: "2241157802"
..........
.......
.....
2018-04-16 09:28:51,686+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler3) [2ed85b17] Failed to parse 'writeRate' value '2290644855' to integer: For input string: "2290644855"
2018-04-16 09:29:36,762+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler4) [3559451d] Failed to parse 'writeRate' value '2271192977' to integer: For input string: "2271192977"
2018-04-16 09:31:06,931+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler7) [19809dbf] Failed to parse 'writeRate' value '3151737835' to integer: For input string: "3151737835"
2018-04-16 09:32:07,064+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler9) [44bc719d] Failed to parse 'writeRate' value '3435967283' to integer: For input string: "3435967283"
2018-04-16 09:33:07,188+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler8) [35f76ee1] Failed to parse 'writeRate' value '3438259456' to integer: For input string: "3438259456"
2018-04-16 09:34:07,291+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler6) [100c181e] Failed to parse 'writeRate' value '3147538317' to integer: For input string: "3147538317"
2018-04-16 09:35:07,417+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler10) [85695ec] Failed to parse 'writeRate' value '2290644855' to integer: For input string: "2290644855"
2018-04-16 09:35:52,504+07 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerObjectsBuilder] (DefaultQuartzScheduler4) [2ce7d1a8] Failed to parse 'writeRate' value '2575347345' to integer: For input string: "2575347345"
-----------------------------------------------

Expected results:
Engine should not throw parse error on receiving huge writeRate from VDSM

Additional info:
I will be attaching the logs shortly.

Comment 1 Yaniv Kaul 2018-04-24 09:25:35 UTC
Are we sure this is a correct rate? >2GB/sec?

Comment 7 Ryan Barry 2019-01-21 14:54:16 UTC
Re-targeting to 4.3.1 since it is missing a patch, an acked blocker flag, or both

Comment 9 Ryan Barry 2019-05-15 03:08:02 UTC
Still not quite reaching 2gb/s, but the data type doesn't have too many side effects on a change

Comment 10 Daniel Gur 2019-08-28 13:12:57 UTC
sync2jira

Comment 11 Daniel Gur 2019-08-28 13:17:09 UTC
sync2jira

Comment 12 Ryan Barry 2020-01-31 14:01:31 UTC
We have not seen a reproducer since this was opened. Please re-open with updated logs if this occurs again


Note You need to log in before you can comment on or make changes to this bug.