Bug 157127 - kgpg fails to show image in key
Summary: kgpg fails to show image in key
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdeutils (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Petr Rockai
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 157128 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 07:03 UTC by Morten Green Hermansen
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 10:05:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Morten Green Hermansen 2005-05-07 07:03:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217

Description of problem:
When adding an image to a keypair it cannot be shown afterwards.

Version-Release number of selected component (if applicable):
kdeutils-3.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Start kgpg from commandline
2. Press right mouse button on own key
3. Select 'Add Photo' on the popup menu
4. Select an jpg image
5. Enter password
6. (The size of the key has actually increased - good)

7. Expand tree on the key (A new line 'Photo id' has appeared)
8. Right click on 'Photo id' and select 'Open photo'
9. <nothing happends>

10. Menu -> View -> Photo ID's -> Small
11. Console prints "QImage::scale: Image is a null image"


Actual Results:  Nothing

Expected Results:  The photo from the key should have been shown.

Additional info:

Comment 1 Suzanne Hillman 2005-05-09 15:50:18 UTC
*** Bug 157128 has been marked as a duplicate of this bug. ***

Comment 2 Petr Rockai 2005-05-20 12:46:44 UTC
This apparently works with KDE from subversion trunk compiled on fedora core   
3. With KDE 3.4 in devel, however, kgpg crashes instead. I suspect   
miscompilation or something similar (from backtrace, the crash seems unrelated   
to kgpg itself, probably kdelibs problem?). I'll look at the problem with  
kdelibs, however, until that is somehow solved, this bug is stalled. 

Comment 3 Petr Rockai 2005-05-30 10:05:49 UTC
Ok, in current fc4 (devel) looks good (image is shown, no crashes). Closing. 


Note You need to log in before you can comment on or make changes to this bug.