Bug 157131 - libgcrypt-devel should be added to build requirements
Summary: libgcrypt-devel should be added to build requirements
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-07 10:13 UTC by David Juran
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-07 19:14:26 UTC
Type: ---


Attachments (Terms of Use)

Description David Juran 2005-05-07 10:13:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
If libgcrypt-devel isn't installed when building the gaim rpm the resulting gaim package will end up without SSL support and without e.g. msn capabilities. It would IMHO be better if there was an error at build time.


Version-Release number of selected component (if applicable):
gaim-1.2.1-1.fc3

How reproducible:
Always

Steps to Reproduce:
1. rpm -e libgrypt-devel
2. rpmbuild --rebuild gaim-1.2.1-1.fc3.src.rpm

  

Actual Results:  The rpm is built, but it's incomplete

Expected Results:  I would prefer if I got a failure that libgcrypt-devel was missing

Additional info:

Comment 1 Stu Tomlinson 2005-05-07 12:12:53 UTC
Gaim's dependency is on gnutls-devel. Gaim does not use libgcrypt directly. I
think the bug here is actually a bug in the gnutls packaging - gnutls-devel
should Require: libgcrypt-devel.

Comment 2 Warren Togami 2005-05-07 19:14:26 UTC
FC4 gnutls already does that.  But I thought I changed gaim-1.2.1 packages to
use mozilla-nss instead?  In any case it is wrong to add this BuildRequires to gaim.



Note You need to log in before you can comment on or make changes to this bug.