Bug 157145 - error: unpacking of archive failed on file /boot/vmlinuz-2.6.11-1.1287_FC4;427cd833: cpio: write
error: unpacking of archive failed on file /boot/vmlinuz-2.6.11-1.1287_FC4;42...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cpio (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-07 11:16 EDT by Clyde E. Kunkel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 11:03:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2005-05-07 11:16:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
Note:  This is probably not a cpio problem, but didn't know where to report this.

During yum update from rawhide, got the following during the installation phase:

Running Transaction
  Installing: kernel                       ######################### [1/3]
error: unpacking of archive failed on file /boot/vmlinuz-2.6.11-1.1287_FC4;427cd833: cpio: write
  Installing: kernel-xenU                  ######################### [2/3]
error: unpacking of archive failed on file /boot/vmlinuz-2.6.11-1.1287_FC4xenU;427cd833: cpio: write
  Installing: kernel-smp                   ######################### [3/3]
error: unpacking of archive failed on file /boot/System.map-2.6.11-1.1287_FC4smp;427cd833: cpio: write

Installed: kernel.i686 0:2.6.11-1.1287_FC4 kernel-smp.i686 0:2.6.11-1.1287_FC4 kernel-xenU.i686 0:2.6.11-1.1287_FC4
Complete!


Only the xen0 kernel was installed.  Saw that the system maps for 2.6.11-1.1287_FC4; 2.6.11-1.1287_FC4smp; and 2.6.11-1.1287_FC4xenU were installed, however the only kernel installed was the xenU kernel.  

Deleted the system.maps and reran with same results.

Ran yum clean packages and reran with same results.

Version-Release number of selected component (if applicable):
cpio-2.6-6

How reproducible:
Always

Steps to Reproduce:
1.yum -y update
2.
3.
  

Actual Results:  Error as described above.

Expected Results:  Normal install of kernels.

Additional info:
Comment 1 Peter Vrabec 2005-05-10 04:31:07 EDT
Do you have enought free disk space on /boot?

Could you try to download packages and install them manualy rpm -U packge.

Comment 2 Clyde E. Kunkel 2005-05-10 11:03:17 EDT
My bad...boot partition was full.  NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.