Bug 1571635 - [RFE]: Provide a friendly error message when container downloads fail due to insecure registry
Summary: [RFE]: Provide a friendly error message when container downloads fail due to ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 08:58 UTC by Udi
Modified: 2020-11-20 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-20 16:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Udi 2018-04-25 08:58:34 UTC
Description of problem:
If downloading containers from an insecure registry, without setting the registry url as insecure, the error message looks something like this:

gui.AllNodesDeploySteps.ControllerDeployment_Step1.2:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: 3cbbb866-eb04-4cf7-b481-cbfd54fab3d9
  status: CREATE_FAILED
  status_reason: |
    Error: resources[2]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
            "2018-04-24 16:24:49,402 ERROR: 22630 -- ERROR configuring neutron",
            "2018-04-24 16:24:49,402 ERROR: 22630 -- ERROR configuring horizon",
            "2018-04-24 16:24:49,402 ERROR: 22630 -- ERROR configuring heat_api_cfn"
        ]
    }
        to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/95f0bc82-c9da-4197-be8b-ee39310c84c8_playbook.retry
   
    PLAY RECAP *********************************************************************
    localhost                  : ok=19   changed=12   unreachable=0    failed=1  
   
    (truncated, view all with --long)
  deploy_stderr: |


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost.noarch
openstack-tripleo-common-containers-8.6.1-0.20180410165748.4d8ca16.el7ost.noarch
openstack-tripleo-common-8.6.1-0.20180410165748.4d8ca16.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Deploy, using the undercloud as a container registry, without setting any DockerInsecureRegistryAddress


Actual results:
Deployment fails with a cryptic error message


Expected results:
An error message like "container download failed due to insecure registry..."

Comment 1 Michael Barnett 2020-11-20 16:43:01 UTC
A lot of work has been put into the error messaging for the recent releases and much has been backported Train. If there are still improvements needed please re-open this or file a new requests as needed.


Note You need to log in before you can comment on or make changes to this bug.