Bug 1571760 - Upgrade from 10 to 11 fails on environments without nova cells.
Summary: Upgrade from 10 to 11 fails on environments without nova cells.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 11:43 UTC by Sergii Golovatiuk
Modified: 2018-06-07 07:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 12:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sergii Golovatiuk 2018-04-25 11:43:43 UTC
Description of problem:

Upgrade from 10 to 11 fails on environments without nova cells.

How reproducible:

Steps to Reproduce:
1. Install RHOSP-10 without nova cells. For instance (undercloud + 1 controller + 1 compute 
2. Run: sudo rhos-release 11 -P
3. Make sure ''nova-manage cell_v2 list_cells' has output as

+-------+------+
|  Name | UUID |
+-------+------+
|  None |      |
+-------+------+
4. Run openstack undercloud upgrade

Actual results:

2018-04-24 05:37:59,731 INFO: Notice: /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns: ValidationError: Cell mappings are not created, but required for Ocata. Please
run nova-manage cell_v2 simple_cell_setup before continuing.
2018-04-24 05:37:59,731 INFO: Error: /usr/bin/nova-manage  api_db sync returned 1 instead of one of [0]
2018-04-24 05:37:59,731 INFO: Error: /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns: change from notrun to 0 failed: /usr/bin/nova-manage  api_db sync returned 1 ins
tead of one of [0]

Upgrade failed.

Expected results:

Passed upgrade.

Additional info:
The easiest way is to create cells by 'nova-manage cell_v2 simple_cell_setup' if they are not created.

Comment 1 Mike Orazi 2018-04-25 11:46:15 UTC
Adding Lee for general information/guidance.  

I think the workaround of detecting lack of cells and creating them if needed would be ok.  Lee can you confirm that such an approach seems reasonable?

Comment 2 Ollie Walsh 2018-04-25 11:56:21 UTC
(In reply to Sergii Golovatiuk from comment #0)
> Description of problem:
> 
> Upgrade from 10 to 11 fails on environments without nova cells.
> 
> How reproducible:
> 
> Steps to Reproduce:
> 1. Install RHOSP-10 without nova cells. For instance (undercloud + 1
> controller + 1 compute 
> 2. Run: sudo rhos-release 11 -P
> 3. Make sure ''nova-manage cell_v2 list_cells' has output as
> 
> +-------+------+
> |  Name | UUID |
> +-------+------+
> |  None |      |
> +-------+------+
> 4. Run openstack undercloud upgrade

How exactly? What was the cli? I suspect an install was run, not an upgrade.

> 
> Actual results:
> 
> 2018-04-24 05:37:59,731 INFO: Notice:
> /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns:
> ValidationError: Cell mappings are not created, but required for Ocata.
> Please
> run nova-manage cell_v2 simple_cell_setup before continuing.
> 2018-04-24 05:37:59,731 INFO: Error: /usr/bin/nova-manage  api_db sync
> returned 1 instead of one of [0]
> 2018-04-24 05:37:59,731 INFO: Error:
> /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns: change from
> notrun to 0 failed: /usr/bin/nova-manage  api_db sync returned 1 ins
> tead of one of [0]
> 
> Upgrade failed.
> 
> Expected results:
> 
> Passed upgrade.
> 
> Additional info:
> The easiest way is to create cells by 'nova-manage cell_v2
> simple_cell_setup' if they are not created.

Do not run simple_cell_setup, it does not result in the same config (e.g default cell name is not the same).

Comment 3 Lee Yarwood 2018-04-25 11:58:31 UTC
(In reply to Ollie Walsh from comment #2)
> (In reply to Sergii Golovatiuk from comment #0)
> > Description of problem:
> > 
> > Upgrade from 10 to 11 fails on environments without nova cells.
> > 
> > How reproducible:
> > 
> > Steps to Reproduce:
> > 1. Install RHOSP-10 without nova cells. For instance (undercloud + 1
> > controller + 1 compute 
> > 2. Run: sudo rhos-release 11 -P
> > 3. Make sure ''nova-manage cell_v2 list_cells' has output as
> > 
> > +-------+------+
> > |  Name | UUID |
> > +-------+------+
> > |  None |      |
> > +-------+------+
> > 4. Run openstack undercloud upgrade
> 
> How exactly? What was the cli? I suspect an install was run, not an upgrade.

Agreed, if this was an undercloud upgrade then please attach the full log to the bug.

Comment 4 Ollie Walsh 2018-04-25 12:04:55 UTC
(In reply to Ollie Walsh from comment #2)
> (In reply to Sergii Golovatiuk from comment #0)
> > Description of problem:
> > 
> > Upgrade from 10 to 11 fails on environments without nova cells.
> > 
> > How reproducible:
> > 
> > Steps to Reproduce:
> > 1. Install RHOSP-10 without nova cells. For instance (undercloud + 1
> > controller + 1 compute 
> > 2. Run: sudo rhos-release 11 -P
> > 3. Make sure ''nova-manage cell_v2 list_cells' has output as
> > 
> > +-------+------+
> > |  Name | UUID |
> > +-------+------+
> > |  None |      |
> > +-------+------+
> > 4. Run openstack undercloud upgrade
> 
> How exactly? What was the cli? I suspect an install was run, not an upgrade.

Or the required packages (e.g python-tripleoclient) were not upgraded before running the undercloud upgrade.

> 
> > 
> > Actual results:
> > 
> > 2018-04-24 05:37:59,731 INFO: Notice:
> > /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns:
> > ValidationError: Cell mappings are not created, but required for Ocata.
> > Please
> > run nova-manage cell_v2 simple_cell_setup before continuing.
> > 2018-04-24 05:37:59,731 INFO: Error: /usr/bin/nova-manage  api_db sync
> > returned 1 instead of one of [0]
> > 2018-04-24 05:37:59,731 INFO: Error:
> > /Stage[main]/Nova::Db::Sync_api/Exec[nova-db-sync-api]/returns: change from
> > notrun to 0 failed: /usr/bin/nova-manage  api_db sync returned 1 ins
> > tead of one of [0]
> > 
> > Upgrade failed.
> > 
> > Expected results:
> > 
> > Passed upgrade.
> > 
> > Additional info:
> > The easiest way is to create cells by 'nova-manage cell_v2
> > simple_cell_setup' if they are not created.
> 
> Do not run simple_cell_setup, it does not result in the same config (e.g
> default cell name is not the same).

Comment 6 Ollie Walsh 2018-04-25 12:42:22 UTC
The documented undercloud upgrade processes must be followed, including the steps to upgrade the python-tripleoclient etc... rpms *before* running the undercloud upgrade command.
As this was not done the result was an OSP9->OSP10 upgrade procedure being performed using OSP11 repositories.

Comment 7 Sergii Golovatiuk 2018-06-07 07:18:09 UTC
Upgrading packages helped. So, it's not a bug


Note You need to log in before you can comment on or make changes to this bug.