Bug 1571827 - appliance_console fails to launch with error Could not find nokogiri-1.6.8 in any of the sources.
Summary: appliance_console fails to launch with error Could not find nokogiri-1.6.8 in...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.8.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Joe Rafaniello
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 13:30 UTC by Prasad Mukhedkar
Modified: 2018-07-05 08:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 13:44:45 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
rpm_package_nonworking_appliance (21.90 KB, text/plain)
2018-06-25 12:04 UTC, Prasad Mukhedkar
no flags Details
rpm_package_working_appliance (21.98 KB, text/plain)
2018-06-25 12:05 UTC, Prasad Mukhedkar
no flags Details
rpm_verification_nonworking_appliance (178 bytes, text/plain)
2018-06-25 12:05 UTC, Prasad Mukhedkar
no flags Details
rpm_verification_working_appliance (229 bytes, text/plain)
2018-06-25 12:06 UTC, Prasad Mukhedkar
no flags Details

Description Prasad Mukhedkar 2018-04-25 13:30:27 UTC
Description of problem:

The command was working fine and suddenly it stopped launching console, execution 
fails with error : 

[root@ieabvlxrcfmel01 ~]# appliance_console
/opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/spec_set.rb:87:in `block in materialize': Could not find nokogiri-1.6.8 in any of the sources (Bundler::GemNotFound)
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/spec_set.rb:81:in `map!'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/spec_set.rb:81:in `materialize'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/definition.rb:159:in `specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/definition.rb:218:in `specs_for'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/definition.rb:207:in `requested_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/runtime.rb:109:in `block in definition_method'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler/runtime.rb:21:in `setup'
        from /opt/rh/cfme-gemset/gems/bundler-1.15.0/lib/bundler.rb:101:in `setup'
        from /bin/appliance_console:4:in `<main>'
[root@ieabvlxrcfmel01 ~]# uptime



Build : 5.8.0.17-20170525183055_6317a22
Nokogiri : rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64
cfme-gemset : cfme-gemset-5.8.0.17-1.el7cf.x86_64
gem : nokogiri (1.6.8)

rpm -V rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64
no modifiction noticed.

Comment 2 Joe Rafaniello 2018-04-25 20:09:12 UTC
> The command was working fine and suddenly it stopped launching console

Were there any package updates?  I can't tell from the support case or the sos logs if there was a cfme upgrade performed, if any packages were updated, or nothing like this.

Was bundle install run? Note, you can't run bundle install as this will invalidate the dependency tree for cfme and found in the Gemfile.lock.

Let's see if the bundle install was run:
rpm -V cfme-gemset

If there is a change to the Gemfile.lock or anything else in this package, we need to reinstall it:
yum reinstall cfme-gemset # if there are any changes found in the first command

Next, you can try looking for any changes in any of the cfme rpms:
rpm -qa |grep cfme | xargs rpm -V $1

In my environment, the only ones I see changed is this:
S.5....T.    /var/www/miq/vmdb/tmp/cache/sti_loader.yml

I'm not sure what else to check.  Please let me know what you find.

Comment 4 Joe Rafaniello 2018-05-01 13:44:45 UTC
The Gemfile.lock was modified by something and the solution they're going to use is yum reinstall cfme-gemset to get it back to the way it was.

Comment 6 Prasad Mukhedkar 2018-06-25 12:04:27 UTC
Created attachment 1454331 [details]
rpm_package_nonworking_appliance

Comment 7 Prasad Mukhedkar 2018-06-25 12:05:04 UTC
Created attachment 1454332 [details]
rpm_package_working_appliance

Comment 8 Prasad Mukhedkar 2018-06-25 12:05:23 UTC
Created attachment 1454333 [details]
rpm_verification_nonworking_appliance

Comment 9 Prasad Mukhedkar 2018-06-25 12:06:33 UTC
Created attachment 1454334 [details]
rpm_verification_working_appliance

Comment 10 Joe Rafaniello 2018-06-26 14:33:13 UTC
Prasad, it looks like the Gemfile.lock is wrong on the non-working appliance.  We use nokogiri 1.8.1 on cfme 5.7.4.2.  The error you're reporting is looking for version 1.6.8.

Please check the Gemfile.lock in /var/www/miq/vmdb/Gemfile.lock.  Note, this is a symlink to the cfme-gemset's Gemfile.lock There should be a line that says:    

nokogiri (= 1.8.1)

If it says 1.6.8, you need to yum reinstall cfme-gemset to fix it.  

If it says 1.8.1, maybe try running appliance_console from /var/www/miq/vmdb and report if that works.

Comment 11 Joe Rafaniello 2018-06-26 14:50:54 UTC
Note, in our private chat, you mentioned the error:

Could not find nokogiri-1.8.1 in any of the sources.  That is a completely different problem from the reported one for 1.6.8.  Please double check what the error is.

The Gemfile.lock should say 1.8.1 as per comment 10.  You should have nokogiri installed, which is confirmed by the package list you provided for both the working non-working appliances:

10:26:39 ~/Downloads/issues/bz1571827 (2.4.4) + grep nokogiri rpm_package_*
rpm_package_nonworking_appliance.txt:rh-ruby23-rubygem-nokogiri-1.8.1-2.el7cf.x86_64
rpm_package_working_appliance.txt:rh-ruby23-rubygem-nokogiri-1.8.1-2.el7cf.x86_64


Note You need to log in before you can comment on or make changes to this bug.