Bug 1571892 - "com.redhat.component" image label must use a "-container" suffix
Summary: "com.redhat.component" image label must use a "-container" suffix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Container
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 3.0
Assignee: Erwan Velu
QA Contact: Harish NV Rao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 15:40 UTC by Ken Dreyer (Red Hat)
Modified: 2018-05-15 19:05 UTC (History)
5 users (show)

Fixed In Version: rhceph:ceph-3.0-rhel-7-containers-candidate-19571-20180503025035
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 19:05:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-container pull 1034 0 None None None 2018-04-25 15:45:10 UTC
Github ceph ceph-container pull 1039 0 None None None 2018-05-01 21:48:04 UTC
Red Hat Product Errata RHBA-2018:1564 0 None None None 2018-05-15 19:05:13 UTC

Description Ken Dreyer (Red Hat) 2018-04-25 15:40:18 UTC
Description of problem:
The "com.redhat.component" label uses a "-docker" suffix. We need to change this to "-container".

-LABEL com.redhat.component="rhceph-rhel7-docker"
+LABEL com.redhat.component="rhceph-rhel7-container"


Version-Release number of selected component (if applicable):
rhceph-rhel7-docker-3-6

How reproducible:
always

Steps to Reproduce:
1. docker pull registry.access.redhat.com/rhceph/rhceph-3-rhel7
2. docker inspect registry.access.redhat.com/rhceph/rhceph-3-rhel7:latest | jq .[].Config.Labels
3. Check the "com.redhat.component" key

Actual results:
The rhceph image's label com.redhat.component label says:

  "com.redhat.component": "rhceph-rhel7-docker",

Expected results:
The rhceph image's label com.redhat.component label says:

  "com.redhat.component": "rhceph-rhel7-container",


Additional info:

Note that in order to preserve upgrades from the GA container image, we need the "release" label to be "7" (or higher).

Ordinarily OSBS will dynamically increment the "release" label to the proper value (see https://github.com/projectatomic/atomic-reactor/blob/master/atomic_reactor/plugins/pre_bump_release.py)

When the component name changes like this, OSBS will not know that the last release was "6" in order to bump it to "7". We must hardcode "release" for our first rhceph-rhel7-container build. The code change would be:

 # Atomic specific labels
 ADD install.sh /install.sh
 LABEL version=3
+LABEL release=7
 LABEL run="/usr/bin/docker run -d --net=host --pid=host -e MON_NAME=\${MON_NAME} -e MON_IP=\${MON_IP}  -e CEPH_PUBLIC_NETWORK=\${CEPH_PUBLIC_NETWORK} -e CEPH_DAEMON=\${CEPH_DAEMON} -v /etc/ceph:/etc/ceph -v /var/lib/ceph:/var/lib/ceph \${IMAGE}"

... and then we can revert this after the first (non-scratch) build is done.

Comment 13 errata-xmlrpc 2018-05-15 19:05:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1564


Note You need to log in before you can comment on or make changes to this bug.