Bug 1571910 - katello-service --only option fail to produce correct result
Summary: katello-service --only option fail to produce correct result
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Other
Version: 6.2.14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 16:50 UTC by DzungDo
Modified: 2019-06-03 12:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description DzungDo 2018-04-25 16:50:26 UTC
Description of problem:
The command katello-service using "--only" option produce wrong result:

Version-Release number of selected component (if applicable):
6.2.14 and capsule

How reproducible:
Always

Steps to Reproduce:
1. Run "katello-service status --help" and review the result:

Usage: katello-service [options] [restart|stop|start|status|list]
        --exclude [SERVICES]         A comma-separated list of services to skip
        --only [SERVICES]            A comma-separated list of services to include

2. From the --help output, it's understood that --exclude should exclude service and --only should give status of the [SERVICES] - comma-separate

3. Run "katello-services --only foo,bar,whatever
Success!

4. Run "katello-services --exclude httpd.service,foreman-tasks.service status
Result returned every services including httpd and foreman-tasks

Actual results:
Option "--only" always return "Success!"
Option "--exclude" never exclude listed services

Expected results:
Should respond with correct message when using "--only"
Should exclude service when using "--exclude"

Additional info:

Comment 7 Bryan Kearney 2019-05-02 19:06:57 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 8 Bryan Kearney 2019-06-03 12:05:47 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.