Bug 1571916 - ovirt-guest-agent.service and NetworkManager-wait-online.service both are failed on undercloud
Summary: ovirt-guest-agent.service and NetworkManager-wait-online.service both are fai...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 17:13 UTC by Alexander Chuzhoy
Modified: 2018-04-25 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 17:39:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2018-04-25 17:13:23 UTC
ovirt-guest-agent.service and NetworkManager-wait-online.service both are failed on undercloud

Environment:
ovirt-guest-agent-common-1.0.13-5.el7ev.noarch                                                                                                                                                NetworkManager-config-server-1.10.2-13.el7.noarch                                                                                                                                             NetworkManager-tui-1.10.2-13.el7.x86_64                                                                                                                                                       instack-undercloud-8.4.0-4.el7ost.noarch                                                                                                                                                      NetworkManager-1.10.2-13.el7.x86_64                                                                                                                                                           NetworkManager-team-1.10.2-13.el7.x86_64                                                                                                                                                      NetworkManager-libnm-1.10.2-13.el7.x86_64   

Steps to reproduce:
deploy undercloud and check systemctlctl for failed services.

Result:
NetworkManager-wait-online.service loaded failed failed Network Manager Wait Online           
ovirt-guest-agent.service loaded failed failed    oVirt Guest Agent 


Expected result:

No failed services.

Comment 1 Alexander Chuzhoy 2018-04-25 17:18:27 UTC
[root@undercloud-0 ~]# journalctl -u NetworkManager-wait-online.service
-- Logs begin at Tue 2018-04-24 09:47:25 EDT, end at Wed 2018-04-25 13:17:41 EDT. --
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: Starting Network Manager Wait Online...
Apr 24 09:47:27 undercloud-0.redhat.local nm-online[596]: gdbusobjectmanagerclient.c:1588: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/IP4Config/2 but no object proxy exists
Apr 24 09:47:27 undercloud-0.redhat.local nm-online[596]: gdbusobjectmanagerclient.c:1588: Processing InterfaceRemoved signal for path /org/freedesktop/NetworkManager/IP6Config/2 but no object proxy exists
Apr 24 09:47:57 undercloud-0.redhat.local systemd[1]: NetworkManager-wait-online.service: main process exited, code=exited, status=1/FAILURE
Apr 24 09:47:57 undercloud-0.redhat.local systemd[1]: Failed to start Network Manager Wait Online.
Apr 24 09:47:57 undercloud-0.redhat.local systemd[1]: Unit NetworkManager-wait-online.service entered failed state.
Apr 24 09:47:57 undercloud-0.redhat.local systemd[1]: NetworkManager-wait-online.service failed.





[root@undercloud-0 ~]# journalctl -u ovirt-guest-agent.service
-- Logs begin at Tue 2018-04-24 09:47:25 EDT, end at Wed 2018-04-25 13:18:01 EDT. --
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: Starting oVirt Guest Agent...
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: Started oVirt Guest Agent.
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: ovirt-guest-agent.service: main process exited, code=exited, status=1/FAILURE
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: Unit ovirt-guest-agent.service entered failed state.
Apr 24 09:47:27 undercloud-0.redhat.local systemd[1]: ovirt-guest-agent.service failed.

Comment 2 Alexander Chuzhoy 2018-04-25 17:25:45 UTC
Restarting ovirt-guest-agent.service doesn't help, it remained failed.


restarting NetworkManager-wait-online.service activates it:

[root@undercloud-0 ~]# systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; vendor preset: enabled)
   Active: active (exited) since Wed 2018-04-25 13:24:39 EDT; 50s ago
     Docs: man:nm-online(1)
  Process: 11962 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, status=0/SUCCESS)
 Main PID: 11962 (code=exited, status=0/SUCCESS)
    Tasks: 0
   CGroup: /system.slice/NetworkManager-wait-online.service

Apr 25 13:24:39 undercloud-0.redhat.local systemd[1]: Starting Network Manager Wait Online...
Apr 25 13:24:39 undercloud-0.redhat.local systemd[1]: Started Network Manager Wait Online.

Comment 4 Alex Schultz 2018-04-25 17:39:35 UTC
We don't install ovirt-guest-agent, so I'm not sure where that's coming from.  

Since neither of these services are part of OSP, I'm inclined to close this as NOTABUG.  If we need to manage these as part of the undercloud install, that would need to be an RFE


Note You need to log in before you can comment on or make changes to this bug.