Bug 1572030 - [3.9 RFE] Change openshift_prometheus_node_exporter_install default value to false
Summary: [3.9 RFE] Change openshift_prometheus_node_exporter_install default value to ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.9.z
Assignee: Aaron Weitekamp
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1572029
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 03:22 UTC by Junqi Zhao
Modified: 2018-12-10 14:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1572029
Environment:
Last Closed: 2018-12-10 14:04:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Junqi Zhao 2018-04-26 03:22:15 UTC
+++ This bug was initially created as a clone of Bug #1572029 +++

Description of problem:
openshift_prometheus_node_exporter_install default value is true, it is better to change to false, since prometheus_node_exporter pods are mainly used by online monitoring team, they can set it to true if they want to deploy prometheus_node_exporter pods.

roles/openshift_prometheus/README.md:- `openshift_prometheus_node_exporter_install`: true (default) or false
roles/openshift_prometheus/defaults/main.yaml:openshift_prometheus_node_exporter_install: true
roles/openshift_prometheus/tasks/main.yaml:  when: openshift_prometheus_node_exporter_install | default(true) | bool

Version-Release number of the following components:
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-docs-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-playbooks-3.10.0-0.29.0.git.0.8973ee4.el7.noarch
openshift-ansible-3.10.0-0.29.0.git.0.8973ee4.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
openshift_prometheus_node_exporter_install default value is true

Expected results:
Change openshift_prometheus_node_exporter_install default value to false

Additional info:

Comment 1 Aaron Weitekamp 2018-12-10 14:04:22 UTC
Not applicable for cluster-monitoring architecture.


Note You need to log in before you can comment on or make changes to this bug.