Bug 157205 - tomcat5 webapp precompilation fails during build
tomcat5 webapp precompilation fails during build
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-09 08:40 EDT by Gary Benson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 04:12:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The exception report from ant -verbose (5.39 KB, text/plain)
2005-10-14 12:17 EDT, Gary Benson
no flags Details

  None (edit)
Description Gary Benson 2005-05-09 08:40:02 EDT
Description of problem:
tomcat5's webapp precompilation fails during build.  It is currently omitted,
and notably causes the failure of the admin webapp.

Version-Release number of selected component (if applicable):
tomcat5-5.0.30-5jpp_5fc
Comment 1 Gary Benson 2005-10-14 11:48:22 EDT
Verified with libgcj-4.0.2-3.
Comment 2 Gary Benson 2005-10-14 12:17:40 EDT
Created attachment 119987 [details]
The exception report from ant -verbose
Comment 3 Gary Benson 2005-10-14 12:28:14 EDT
From my original workaround:
> RequestUtils.applicationClass() uses the context classloader to find
> the class, but for some reason it sometimes seems to be set to what
> looks like the normal system classloader.  Possibly its something to
> do with the fact that MessageResourcesFactory.createFactory() is
> called from MessageResources.getMessageResources() which is usually
> called from <clinit> methods.  Or, it could be because RequestUtils
> itself calls getMessageResources(), so createFactory() reenters
> itself.
Comment 4 Red Hat Bugzilla 2007-02-05 14:03:44 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Note You need to log in before you can comment on or make changes to this bug.