Bug 1572261 - [RFE] OIDC authentication support
Summary: [RFE] OIDC authentication support
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Authentication
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-26 14:34 UTC by Eduardo Minguez
Modified: 2019-11-04 14:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 14:01:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eduardo Minguez 2018-04-26 14:34:16 UTC
Description of problem: Current satellite installer procedure doesn't support OpenID integration

Version-Release number of selected component (if applicable): 6.3.1

How reproducible: Look for OpenID integration options in the Satellite installer

Steps to Reproduce:
1. Attempt to configure Satellite 6 to consume external authentication/users via OpenID

Actual results: No satellite-installer options.

Expected results:

There are satellite-installer options to achieve that setup.

Additional info:

Comment 1 Bryan Kearney 2019-11-04 14:01:23 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.