Bug 157229 - error from rpm -qa -- error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error from rpm -qa -- error: db4 error(-30989) from dbcursor->c_get: DB_PAG...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-09 12:42 EDT by MIdRange Support
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm log (18.83 KB, text/plain)
2005-05-09 13:18 EDT, MIdRange Support
no flags Details

  None (edit)
Description MIdRange Support 2005-05-09 12:42:45 EDT
Description of problem: RPM db appears to be corrupt


Version-Release number of selected component (if applicable):
rpm-4.2.2-0.14

How reproducible: Unknown


Steps to Reproduce:
1. This was a new install of AS3 update 2
2. I had installed HP Proliant support pack
3.
  
Actual results:
[root@hsg05lt post-install]# rpm -qa
setup-2.5.27-1
tzdata-2003c-1
bzip2-libs-1.0.2-11
e2fsprogs-1.32-15
gdbm-1.8.0-20
hdparm-5.4-1
libtermcap-2.0.8-35
bash-2.05b-29
mount-2.11y-31.1
raidtools-1.00.3-7
slang-1.4.5-18
words-2-21
info-4.5-3
gawk-3.1.1-9
grub-0.93-4
ncurses-5.3-9.3
openssl-0.9.7a-33.4
python-2.2.3-5
sed-4.0.7-3
kudzu-1.1.22.2-1
mkinitrd-3.5.13-1
which-2.14-7
kernel-2.4.21-15.EL
libuser-0.51.7-1
redhat-config-mouse-1.0.13-1
rmt-0.4b28-7
dosfstools-2.8-10
jfsutils-1.1.2-2
acl-2.2.3-1
lslk-1.29-8
crontabs-1.10-5
ncompress-4.2.4-33
patch-2.5.4-16
perl-Filter-1.29-3
rdate-1.3-2
rsync-2.5.7-1
netconfig-0.8.19-1
star-1.5a08-4
traceroute-1.4a12-20
XFree86-libs-data-4.3.0-62.EL
libpng-1.2.2-16
elfutils-0.91-3
krb5-workstation-1.2.7-21
m4-1.4.1-13
mtools-3.9.8-8
mtr-0.52-2
cups-libs-1.1.17-13.3.6
pinfo-0.6.6-4
ftp-0.17-17
rhnlib-1.3-12
sharutils-4.2.1-16
sysreport-1.3.7-1
telnet-0.17-26
wget-1.8.2-15
devlabel-0.42.05-2.1
iptables-1.2.8-12.3
autofs-3.1.7-41
openssh-clients-3.6.1p2-33.30.1
portmap-4.0-56
redhat-config-securitylevel-tui-1.2.9-1
tcpdump-3.7.2-7.E3.1
vixie-cron-3.0.1-74
xinetd-2.3.12-2.3E
enscript-1.6.1-24
perl-Parse-Yapp-1.05-30
perl-libxml-perl-0.07-28
perl-XML-Grove-0.46alpha-25
ghostscript-fonts-5.50-9
a2ps-4.13b-28
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested 
page not found



Expected results:
expected a full list of installed packages; about 660 pkgs


Additional info:
I tried to rebuild rh RPM db.

[root@hsg05lt post-install]# rpm -v --rebuilddb
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested 
page not found

Now I get the following
[root@hsg05lt post-install]# rpm -q rpm
package rpm is not installed
[root@hsg05lt post-install]# rpm -qa
tzdata-2003c-1
e2fsprogs-1.32-15
hdparm-5.4-1
bash-2.05b-29
raidtools-1.00.3-7
words-2-21
gawk-3.1.1-9
ncurses-5.3-9.3
python-2.2.3-5
kudzu-1.1.22.2-1
which-2.14-7
libuser-0.51.7-1
rmt-0.4b28-7
jfsutils-1.1.2-2
lslk-1.29-8
ncompress-4.2.4-33
perl-Filter-1.29-3
rsync-2.5.7-1
star-1.5a08-4
XFree86-libs-data-4.3.0-62.EL
elfutils-0.91-3
m4-1.4.1-13
mtr-0.52-2
pinfo-0.6.6-4
rhnlib-1.3-12
sysreport-1.3.7-1
wget-1.8.2-15
iptables-1.2.8-12.3
openssh-clients-3.6.1p2-33.30.1
redhat-config-securitylevel-tui-1.2.9-1
vixie-cron-3.0.1-74
enscript-1.6.1-24
perl-libxml-perl-0.07-28
ghostscript-fonts-5.50-9
setup-2.5.27-1
bzip2-libs-1.0.2-11
gdbm-1.8.0-20
libtermcap-2.0.8-35
mount-2.11y-31.1
slang-1.4.5-18
info-4.5-3
grub-0.93-4
openssl-0.9.7a-33.4
sed-4.0.7-3
mkinitrd-3.5.13-1
kernel-2.4.21-15.EL
redhat-config-mouse-1.0.13-1
dosfstools-2.8-10
acl-2.2.3-1
crontabs-1.10-5
patch-2.5.4-16
rdate-1.3-2
netconfig-0.8.19-1
traceroute-1.4a12-20
libpng-1.2.2-16
krb5-workstation-1.2.7-21
mtools-3.9.8-8
cups-libs-1.1.17-13.3.6
ftp-0.17-17
sharutils-4.2.1-16
telnet-0.17-26
devlabel-0.42.05-2.1
autofs-3.1.7-41
portmap-4.0-56
tcpdump-3.7.2-7.E3.1
xinetd-2.3.12-2.3E
perl-Parse-Yapp-1.05-30
perl-XML-Grove-0.46alpha-25
a2ps-4.13b-28
[root@hsg05lt post-install]#
Comment 1 Paul Nasrat 2005-05-09 13:05:43 EDT
Could you give me some more context on what you were doing prior to install.

I can talk you through rebuilding the rpmdb, but it'd be nice if I could get
some data on what led to hitting DB_PAGE_NOTFOUND.  Can you check if
/var/log/rpmpkgs* exist and if they contain the packages you'd expect.

Did you back up your rpmdb prior to rebuilding by any chance?

Comment 2 MIdRange Support 2005-05-09 13:18:19 EDT
Created attachment 114166 [details]
rpm log
Comment 3 MIdRange Support 2005-05-09 13:19:50 EDT
No RPM db backup.
Comment 4 Paul Nasrat 2005-05-11 11:54:37 EDT
Is this the support pack you refer to
http://h18000.www1.hp.com/support/files/server/us/download/18425.html

Is it reproducible or did it occur just on one system? DB_PAGE_NOTFOUND is quite
hard to reproduce, please let me know if you can reproduce and what steps you
went through to install the service pack.  I'm investingating, but having a
reproducer is pretty essential to be able to test any potential fixes.

To restore your rpmdb assemble the rpms from the original install - you can
rereference the rpmpkgs file.  Place in a dir with the rpmpkgs file (or if it's
logrotated rpmpkgs.1). You can use the rpmpkgs file as a manifest for rpm:

rpm --justdb --notriggers --noscripts rpmpkgs

That should restore your db.

Comment 5 MIdRange Support 2005-05-11 12:05:20 EDT
Similar:
http://h18000.www1.hp.com/support/files/server/us/locate/101_5561.html

I had this happen to another server early in the install.  It would have had 
PSP 7.1.0.  I reinstalled the OS to get around the problem.

Comment 6 Prentice Bisbal 2005-06-30 17:16:16 EDT
I had the same problem. It happened on fresh install of RHEL3ES, no update
level. After running up2date. I did an rpm -qa and got a bunch of DB error
messages. Then I ran rpm --rebuilddb, whic gave me the same error as above. For
some reason, running rpm -v --rebuilddb completed with no errors. 

HOWEVER, I then tried to recompile an SRPM, and got a bunch of errors about
dependencies not being met. I had compiled this same RPM while running up2date,
and it compiled fine, with no errors. (I was recompiling to test something). So
it looks like my rpm DB is still somehow corrupted - the dependency information
is all screwed up. 
Comment 7 Jeff Johnson 2006-01-19 21:31:55 EST
This will be almost impossible to duplicate.
Comment 8 David Lawrence 2006-04-18 16:11:56 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.
Comment 9 John Schneider 2006-05-26 09:20:49 EDT
I believe that we have the same issue on one of our systems with RHEL3ES.  I 
have an open RedHat Support Ticket (871142) with plenty of documentation and 
screen-shots.  I hope that this information will help you find the problem.  
Please let me know if I can provide you with any other information.
Comment 10 Paul Nasrat 2006-05-26 09:28:46 EDT
Please update the support ticket with information on this bug number so the
relevant information can be propogated here.
Comment 11 RHEL Product and Program Management 2007-10-19 15:02:47 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.