Bug 1572857 - Need remove unused package atomic-openshift-master instead of updated it
Summary: Need remove unused package atomic-openshift-master instead of updated it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.z
Assignee: Russell Teague
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 07:56 UTC by liujia
Modified: 2018-10-08 14:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
During an upgrade from 3.9, when the node packages are updated, the atomic-openshift package has a dependency on atomic-openshift-master package. This results in the master package being updated to 3.10. This package is not necessary on 3.10 and is removed during the control plane upgrade.
Clone Of:
Environment:
Last Closed: 2018-10-08 14:02:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description liujia 2018-04-28 07:56:20 UTC
Description of problem:
After upgrade to v3.10 from v3.9, unused packages should be removed instead of updated, such as atomic-openshift-master.

# rpm -qa|grep openshift
atomic-openshift-clients-3.10.0-0.30.0.git.0.0b0a7a3.el7.x86_64
atomic-openshift-master-3.10.0-0.30.0.git.0.0b0a7a3.el7.x86_64
atomic-openshift-excluder-3.10.0-0.30.0.git.0.0b0a7a3.el7.noarch
atomic-openshift-3.10.0-0.30.0.git.0.0b0a7a3.el7.x86_64
atomic-openshift-docker-excluder-3.10.0-0.30.0.git.0.0b0a7a3.el7.noarch
atomic-openshift-node-3.10.0-0.30.0.git.0.0b0a7a3.el7.x86_64


Version-Release number of the following components:
openshift-ansible-3.10.0-0.30.0.git.0.4f02952.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. rpm install ocp v3.9
2. upgrade above ocp
3.

Actual results:
unused package atomic-openshift-master was updated.

Expected results:
remove unused atomic-openshift-master.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag


Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2018-05-21 13:36:21 UTC
Not a blocker for 3.10

Comment 2 Scott Dodson 2018-08-02 12:54:45 UTC
I believe this package is ultimately removed later in the process. need to verify that.

Comment 4 Russell Teague 2018-08-17 18:29:36 UTC
release-3.10: https://github.com/openshift/openshift-ansible/pull/9658

Comment 5 Russell Teague 2018-08-21 19:47:31 UTC
openshift-ansible-3.10.33-1

Comment 8 liujia 2018-09-12 07:14:57 UTC
Verified on openshift-ansible-3.10.45-1.git.0.5aef941.el7.noarch

Before upgrade:
[root@ip-172-18-12-95 ~]# rpm -qa|grep openshift
atomic-openshift-master-3.9.43-1.git.0.7ad1066.el7.x86_64
atomic-openshift-sdn-ovs-3.9.43-1.git.0.7ad1066.el7.x86_64
atomic-openshift-clients-3.9.43-1.git.0.7ad1066.el7.x86_64
atomic-openshift-excluder-3.9.43-1.git.0.7ad1066.el7.noarch
atomic-openshift-docker-excluder-3.9.43-1.git.0.7ad1066.el7.noarch
atomic-openshift-3.9.43-1.git.0.7ad1066.el7.x86_64
atomic-openshift-node-3.9.43-1.git.0.7ad1066.el7.x86_64

After upgrade:
[root@ip-172-18-12-95 ~]# rpm -qa|grep openshift
atomic-openshift-excluder-3.10.45-1.git.0.3b98bf6.el7.noarch
atomic-openshift-node-3.10.45-1.git.0.3b98bf6.el7.x86_64
atomic-openshift-docker-excluder-3.10.45-1.git.0.3b98bf6.el7.noarch
atomic-openshift-hyperkube-3.10.45-1.git.0.3b98bf6.el7.x86_64
atomic-openshift-3.10.45-1.git.0.3b98bf6.el7.x86_64
atomic-openshift-clients-3.10.45-1.git.0.3b98bf6.el7.x86_64

Unused atomic-openshift-master and atomic-openshift-sdn-ovs were removed.


Note You need to log in before you can comment on or make changes to this bug.