Bug 1572923 - Unable to run functional tests on RHEL 7.5
Summary: Unable to run functional tests on RHEL 7.5
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: zstream
: 13.0 (Queens)
Assignee: Lucas Alvares Gomes
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 18:22 UTC by Arie Bregman
Modified: 2019-09-09 17:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-21 08:42:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arie Bregman 2018-04-28 18:22:36 UTC
Description of problem:

When running gate hook[1], before running the actual tests, I get the following failure:

16:00:41 /home/cloud-user/new/ovs/datapath/linux/vport-internal_dev.c:157:2: error: unknown field ‘ndo_change_mtu’ specified in initializer
16:00:41   .ndo_change_mtu = internal_dev_change_mtu,
16:00:41   ^

This happens on RHEL 7.5 but not on RHEL 7.4 for some reason.

Until this bug is resolved, I switched to RHEL 7.4 so we can unblock testing OVN.


[1] networking-ovn/networking_ovn/tests/contrib/gate_hook.sh;
 
Version-Release number of selected component (if applicable): Latest available OSP 13


How reproducible: 100%


Steps to Reproduce:
1. Clone networking-ovn repo
2. Run gate hook

Comment 5 Daniel Alvarez Sanchez 2018-05-10 14:13:24 UTC
I sent the fix to OVS [0] to avoid the compilation errors. This will help upstream but in downstream I think that we should skip compiling the modules in the CI job.

[0] https://mail.openvswitch.org/pipermail/ovs-dev/2018-May/346811.html

Comment 6 Lucas Alvares Gomes 2018-05-10 14:18:29 UTC
(In reply to Daniel Alvarez Sanchez from comment #5)
> I sent the fix to OVS [0] to avoid the compilation errors. This will help
> upstream but in downstream I think that we should skip compiling the modules
> in the CI job.
> 
> [0] https://mail.openvswitch.org/pipermail/ovs-dev/2018-May/346811.html

Yeah, we will need a backport to the 2.9 branch as well because the networking-ovn job with CentOS uses the released version of OVS.

Comment 7 Lucas Alvares Gomes 2018-05-11 08:39:02 UTC
FYI, here's a more complete patch for this problem: https://patchwork.ozlabs.org/patch/911232/

I've reviewed it today and it works for me.

Comment 9 Lucas Alvares Gomes 2018-05-15 10:28:22 UTC
(In reply to Lucas Alvares Gomes from comment #7)
> FYI, here's a more complete patch for this problem:
> https://patchwork.ozlabs.org/patch/911232/
> 
> I've reviewed it today and it works for me.

FWIW, the patch is now merged upstream in OVS. It has also been backported to the branches 2.9 and 2.8

Comment 14 Prasad 2018-07-11 17:38:27 UTC
This is not related to the RedHat release but related to the CentOS 7.5.

I am getting similar issue while compiling CentOS 7.5 kernel 3.10.0-862.6.3.el7 with CONFIG_NET_VENDOR_DLINK=y and CONFIG_SUNDANCE=m. Is there any patch available for CentOS 7.5 kernel.

Comment 15 Arie Bregman 2018-07-13 08:26:54 UTC
Prasad, since this bug is closed, can you open a new bug describing the issue + providing the relevant logs?


Note You need to log in before you can comment on or make changes to this bug.